Функция ЕСЛИ в Excel

Написание знака «не равно» Прежде всего, нужно сказать, что в Экселе существует два знака «не равно»: «» и «≠». Первый из них используется для вычислений, а второй исключительно для графического отображения. Символ «» Элемент «» применяется в логических формулах Эксель, когда нужно показать неравенство аргументов. Впрочем, его можно применять и для визуального обозначения, так как

Синтаксис функции ЕСЛИ с одним условием

Синтаксис оператора в Excel – строение функции, необходимые для ее работы данные.

=ЕСЛИ (логическое_выражение;значение_если_истина;значение_если_ложь)

Разберем синтаксис функции:

Логическое_выражение – ЧТО оператор проверяет (текстовые либо числовые данные ячейки).

Значение_если_истина – ЧТО появится в ячейке, когда текст или число отвечают заданному условию (правдивы).

Значение,если_ложь – ЧТО появится в графе, когда текст или число НЕ отвечают заданному условию (лживы).

Пример:

Логическая функция ЕСЛИ.

Оператор проверяет ячейку А1 и сравнивает ее с 20. Это «логическое_выражение». Когда содержимое графы больше 20, появляется истинная надпись «больше 20». Нет – «меньше или равно 20».

Внимание! Слова в формуле необходимо брать в кавычки. Чтобы Excel понял, что нужно выводить текстовые значения.

Еще один пример. Чтобы получить допуск к экзамену, студенты группы должны успешно сдать зачет. Результаты занесем в таблицу с графами: список студентов, зачет, экзамен.

Логический оператор в таблице.

Обратите внимание: оператор ЕСЛИ должен проверить не цифровой тип данных, а текстовый. Поэтому мы прописали в формуле В2= «зач.». В кавычки берем, чтобы программа правильно распознала текст.

Технические сведения

Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

Синтаксис

  • ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

  • ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

  • ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

Имя аргумента

Описание

лог_выражение (обязательно)

Условие, которое нужно проверить.

значение_если_истина (обязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

значение_если_ложь (необязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Общие сведения об использовании этих функций по отдельности см. в следующих статьях: И, ИЛИ, НЕ. При сочетании с оператором ЕСЛИ они расшифровываются следующим образом:

  • И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

  • ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

  • НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

Знак «не равно» в Excel

1557384556_1.png

С элементом «не равно» у пользователей Excel довольно часто возникают трудности, ведь его нет на клавиатуре, в отличие от «больше» (>) и «меньше» ( — применяется в вычислениях.
2. «≠» — создан только для графического отображения.

Элемент «» применяется в логических формулах Excel для обозначения неравенства аргументов. Иногда его применяют и для визуального обозначения в качестве «не равно».

1557384962_2.png

1557384996_3.png

2. Перед вами откроется окно выбора символов. В параметре «Набор» нужно выбрать пункт «Основная латиница». В центре окна мы видим большое количество различных элементов, многие из которых не присутствуют на стандартной клавиатуре. Чтобы получить знак «», нужно найти соответствующие символы по одному и нажать на кнопку «Вставить».

1557385007_4.png

Как получить символ «≠»

Этот знак не подойдет для использования в логических вычислениях, его принадлежность исключительно визуальная. Элемент «≠» не получится набрать на клавиатуре, поэтому придется использовать другие методы.
1. Проводим те же самые действия, что и при вставке знака «».

1557384943_5.png

1557384959_7.png

Знак «≠» визуально воспринимается гораздо приятнее, чем «». Но стоит помнить, что в расчетах можно использовать лишь второй элемент.

Функция ЕСЛИ с одним условием

Это самый простой пример. Задача стоит: тем студентам, у которых оценка выше сорока баллов – поставить отметку «Зачет», остальным – не ставить никаких отметок. Напишем формулу: =ЕСЛИ(B3>40;»Зачёт»;»»). Скопируем её во все строки таблицы:

Функция ЕСЛИ

Простейший пример применения.

Предположим, вы работаетев компании, которая занимается продажей шоколада в нескольких регионах иработает с множеством покупателей.

Нам необходимо выделитьпродажи, которые произошли в нашем регионе, и те, которые были сделаны за рубежом.Для этого нужно добавить в таблицу ещё один признак для каждой продажи – страну,в которой она произошла. Мы хотим, чтобы этот признак создавался автоматическидля каждой записи (то есть, строки).

В этом нам поможетфункция ЕСЛИ. Добавим в таблицу данных столбец “Страна”. Регион “Запад” – этоместные продажи («Местные»), а остальные регионы – это продажи за рубеж («Экспорт»).

Формула ЕСЛИ в Excel – примеры нескольких условий

Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

Несколько условий в функции ЕСЛИ

Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2<1, то условия B2<0,9 и B2<0,95 Excel бы просто «не заметил», т.к. они входят в интервал B2<1 который проверился бы первым (если значение менее 0,9, само собой, оно также меньше и 1). И тогда у нас получилось бы только два возможных варианта: менее 1 и альтернативное, т.е. 1 и более.

При написании формулы легко запутаться, поэтому рекомендуется смотреть на всплывающую подсказку.

Подсказка функции

В конце нужно обязательно закрыть все скобки, иначе эксель выдаст ошибку

Ошибка из-за нехватки скобки

Формула ЕСЛИ с несколькими условиями в Эксель

При необходимости задать несколько правил достаточно вместо одного из исходов (выполнение/невыполнение) начать писать новую формулу

Пример №2

То же самое, что и в первом примере, но, когда система найдет 0, то напишет «Равно нулю».

Формула ЕСЛИ в Excel: примеры использования

Как правильно записать?

Устанавливаем курсор вячейку G2 ивводим знак “=”. Для Excel это означает, что сейчас будет введена формула. Поэтомукак только далее будет нажата буква “е”, мы получим предложение выбратьфункцию, начинающуюся этой буквы. Выбираем “ЕСЛИ”.

Далее все наши действиятакже будут сопровождаться подсказками.

В качестве первого аргумента записываем: С2=”Запад”. Как и в других функциях Excel, адрес ячейки можно не вводить вручную, а просто кликнуть на ней мышкой. Затем ставим “,” и указываем второй аргумент.

Второй аргумент – этозначение, которое примет ячейка G2, если записанное нами условие будет выполнено. Этобудет слово “Местные”.

После этого снова через запятуюуказываем значение третьего аргумента. Это значение примет ячейка G2, если условие не будетвыполнено: “Экспорт”. Не забываем закончить ввод формулы, закрыв скобку и затемнажав “Enter”.

Наша функция выглядитследующим образом:

=ЕСЛИ(C2=”Запад”,”Местные”,”Экспорт”)

Наша ячейка G2 приняла значение «Местные».

Теперь нашу функцию можноскопировать во все остальные ячейки столбца G.

Функция СУММЕСЛИ в Excel

А теперь перейдем к разновидностям функции ЕСЛИ, которые помогут выполнить заменить сразу два пункта алгоритма. Первая из них – СУММЕСЛИ, которая складывает два числа, которые соответствуют определенному условию. Например, перед нами стоит задача определить, сколько денег нужно платить в месяц всем продавцам. Для этого необходимо.

  1. Добавить ряд с общими доходами всех продавцов и нажать по ячейке, в которой будет находиться результат после ввода формулы. 
  2. Находим кнопку fx, которая находится рядом со строчкой для формул. Далее появится окошко, где посредством поиска можно отыскать необходимую функцию. После выбора оператора нужно нажать кнопку «ОК». Но всегда возможен ручной ввод.

    Функция ЕСЛИ в Excel. Примеры (с несколькими условиями)11

  3. Далее появится окно ввода аргументов функции.  Все значения можно указать в соответствующих полях, а диапазон ввести через кнопку рядом с ними.

    Функция ЕСЛИ в Excel. Примеры (с несколькими условиями)12

  4. Первый аргумент – диапазон. Сюда вводятся ячейки, которые нужно проверять на предмет соответствия критериям. Если говорить про нас – это должности работников. Вводим диапазон D4:D18. Или же просто осуществить выделение интересующих ячеек.
  5. В поле «Критерий» следует ввести должность. В случае с нами – «продавец». Как диапазон суммирования, указываем те ячейки, где перечислены заработные платы сотрудников (это делается как вручную, так и выделить их с помощью мыши). Нажимаем «ОК», и получаем готовую посчитанную заработную плату всех сотрудников, являющихся продавцами.

Согласитесь, что это очень удобно. Не так ли?

Расширение функционала с помощью операторов «И» и «ИЛИ»

Когда нужно проверить несколько истинных условий, используется функция И. Суть такова: ЕСЛИ а = 1 И а = 2 ТОГДА значение в ИНАЧЕ значение с.

Функция ИЛИ проверяет условие 1 или условие 2. Как только хотя бы одно условие истинно, то результат будет истинным. Суть такова: ЕСЛИ а = 1 ИЛИ а = 2 ТОГДА значение в ИНАЧЕ значение с.

Функции И и ИЛИ могут проверить до 30 условий.

Пример использования оператора И:

Пример логического оператора И.

Пример использования функции ИЛИ:

Пример логического оператора ИЛИ.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Как сравнить данные в двух таблицах

Пользователям часто приходится сравнить две таблицы в Excel на совпадения. Примеры из «жизни»: сопоставить цены на товар в разные привозы, сравнить балансы (бухгалтерские отчеты) за несколько месяцев, успеваемость учеников (студентов) разных классов, в разные четверти и т.д.

Чтобы сравнить 2 таблицы в Excel, можно воспользоваться оператором СЧЕТЕСЛИ. Рассмотрим порядок применения функции.

Для примера возьмем две таблицы с техническими характеристиками разных кухонных комбайнов. Мы задумали выделение отличий цветом. Эту задачу в Excel решает условное форматирование.

Исходные данные (таблицы, с которыми будем работать):

Две таблицы для сравнения.

Выделяем первую таблицу. Условное форматирование – создать правило – использовать формулу для определения форматируемых ячеек:

Условное форматирование в таблице.

В строку формул записываем: =СЧЕТЕСЛИ (сравниваемый диапазон; первая ячейка первой таблицы)=0. Сравниваемый диапазон – это вторая таблица.

Условия для форматирования ячеек.

Чтобы вбить в формулу диапазон, просто выделяем его первую ячейку и последнюю. «= 0» означает команду поиска точных (а не приблизительных) значений.

Выбираем формат и устанавливаем, как изменятся ячейки при соблюдении формулы. Лучше сделать заливку цветом.

Выделяем вторую таблицу. Условное форматирование – создать правило – использовать формулу. Применяем тот же оператор (СЧЕТЕСЛИ).

Логический оператор СЧЕТЕСЛИ.

Скачать все примеры функции ЕСЛИ в Excel

Здесь вместо первой и последней ячейки диапазона мы вставили имя столбца, которое присвоили ему заранее. Можно заполнять формулу любым из способов. Но с именем проще.

Функция Если в Excel примеры с несколькими условиями

Пример 1. Проверяем простое числовое условие с помощью функции IF (ЕСЛИ)

При использовании функции ЕСЛИ в Excel, вы можете использовать различные операторы для проверки состояния. Вот список операторов, которые вы можете использовать:

IF-EXCEL-03

Ниже приведен простой пример использования функции при расчете оценок студентов. Если сумма баллов больше или равна “35”, то формула возвращает “Сдал”, иначе возвращается “Не сдал”.

Excel-IF-04

См. также

Узнайте, как использовать вложенные функции в формуле

Функция ЕСЛИ

Функция И

Функция ИЛИ

НЕ

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Сочетания клавиш в Excel

Логические функции (справочник)

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...