ЗАНЯТИЕ 6. ИСПОЛЬЗОВАНИЕ ЛОГИЧЕСКИХ ФУНКЦИЙ В MS EXCEL – ____Работа в MS Excel____

Логические функции в excel с примерами использования и описанием каждой функции. Где можно найти все инструменты на главной панели.

Использование логических функций в Excel

Название функции Значение Синтаксис Примечание
ИСТИНА Не имеет аргументов, возвращает логическое значение «ИСТИНА». =ИСТИНА () Редко используется в качестве самостоятельной функции.
ЛОЖЬ Не имеет аргументов, возвращает логическое выражение «ЛОЖЬ». =ЛОЖЬ () ——-//——-
И Если все заданные аргументы возвращают истинный результат, то функция выдает логическое выражение «ИСТИНА». В случае хотя бы одного ложного логического значения вся функция выдает результат «ЛОЖЬ». =И (Лог_знач. 1; Лог_знач. 2;…) Принимает до 255 аргументов в виде условий или ссылок. Обязательным является первый.
ИЛИ Показывает результат «ИСТИНА», если хотя бы один из аргументов является истинным. =ИЛИ (Лог_знач.1; Лог_знач. 2;…) ——-//——-
НЕ Меняет логическое значение «ИСТИНА» на противоположное – «ЛОЖЬ». И наоборот. #ИМЯ? Обычно сочетается с другими операторами.
ЕСЛИ Проверяет истинность логического выражения и возвращает соответствующий результат. #ИМЯ? «Логическое_выражение» при вычислении должно иметь результат «ИСТИНА» или «ЛОЖЬ».
ЕСЛИОШИБКА Если значение первого аргумента истинно, то возвращает сам аргумент. В противном случае – значение второго аргумента. #ИМЯ? Оба аргумента обязательны.

Основные логические функции, используемые в Эксель

Перечень наиболее часто используемых логических операторов можно ограничить следующим набором:

  • ИСТИНА;
  • ЛОЖЬ;
  • ЕСЛИ;
  • ЕСЛИОШИБКА;
  • ИЛИ;
  • И;
  • НЕ;
  • ЕОШИБКА;
  • ЕПУСТО.

В большинстве случаев их достаточно для построения сложных логических конструкций и задания условий.

Для каждого из указанных выше операторов существуют аргументы (за исключением функций ИСТИНА и ЛОЖЬ) – это могут быть как цифровые или текстовые значения, так и ссылки на данные, содержащиеся в других ячейках.

СУММ

Формула:

=СУММ(число1; число2)

=СУММ(адрес_ячейки1; адрес_ячейки2)

=СУММ(адрес_ячейки1:адрес_ячейки6)

Англоязычный вариант: =SUM(5; 5) или =SUM(A1; B1) или =SUM(A1:B5)

Функция СУММ позволяет вычислить сумму двух или более чисел. В этой формуле вы также можете использовать ссылки на ячейки.

С помощью формулы вы можете:

  • посчитать сумму двух чисел c помощью формулы: =СУММ(5; 5)
  • посчитать сумму содержимого ячеек, сссылаясь на их названия: =СУММ(A1; B1)
  • посчитать сумму в указанном диапазоне ячеек, в примере во всех ячейках с A1 по B6: =СУММ(A1:B6)

Логическая операция ИЛИ

=ИЛИ(A1;B1)

Используем Excel для построения таблицы истинности

Функция ЛОЖЬ

Аналогична функции ИСТИНА, за исключением то, что возвращает противоположный результат ЛОЖЬ.

Синтаксис: =ЛОЖЬ()

СЧЁТ

Формула: =СЧЁТ(адрес_ячейки1:адрес_ячейки2)

Англоязычный вариант: =COUNT(A1:A10)

Данная формула подсчитывает количество ячеек с числами в одном ряду. Если вам необходимо узнать, сколько ячеек с числами находятся в диапазоне c A1 по A30, нужно использовать следующую формулу: =СЧЁТ(A1:A30).

Функция ЕСЛИОШИБКА

Предназначена для проверки возврата выражением ошибки. Если ошибка обнаружена, то она возвращает значение второго аргумента, иначе первого.

Функция принимает 2 аргумента, все они являются обязательными.

Синтаксис: =ЕСЛИОШИБКА(значение;значение_если_ошибка)

Пример использования функции:

В приведенном примере видно, что выражение в первом аргументе возвращает ошибку деления на ноль, но так как оно вложено в нашу функцию, то ошибка перехватывается и подменяется вторым аргументов, а именно строкой «Делить на ноль нельзя», которую мы ввели самостоятельно. Вместо данной строки могли бы быть другие функции, все зависит от поставленной перед Вами задачи.

iferr.png

Логические функции в Excel и примеры решения задач

Задача 1. Необходимо переоценить товарные остатки. Если продукт хранится на складе дольше 8 месяцев, уменьшить его цену в 2 раза.

Сформируем таблицу с исходными параметрами:

Накладная.

Чтобы решить поставленную задачу, воспользуемся логической функцией ЕСЛИ. Формула будет выглядеть так: =ЕСЛИ(C2>=8;B2/2;B2).

Логическое выражение «С2>=8» построено с помощью операторов отношения «>» и «=». Результат его вычисления – логическая величина «ИСТИНА» или «ЛОЖЬ». В первом случае функция возвращает значение «В2/2». Во втором – «В2».

Пример.

Усложним задачу – задействуем логическую функцию И. Теперь условие такое: если товар хранится дольше 8 месяцев, то его стоимость уменьшается в 2 раза. Если дольше 5 месяцев, но меньше 8 – в 1,5 раза.

Формула приобретает следующий вид: .

Пример1.

В функции ЕСЛИ можно использовать в качестве аргументов текстовые значения.

Задача 2. Если стоимость товара на складе после уценки стала меньше 300 р. или продукт хранится дольше 10 месяцев, его списывают.

Для решения используем логические функции ЕСЛИ и ИЛИ: . Условие, записанное с помощью логической операции ИЛИ, расшифровывается так: товар списывается, если число в ячейке D2 = 10.

Пример2.

При невыполнении условия функция ЕСЛИ возвращает пустую ячейку.

В качестве аргументов можно использовать другие функции. К примеру, математические.

Задача 3. Ученики перед поступлением в гимназию сдают математику, русский и английский языки. Проходной балл – 12. По математике для поступления нужно получить не менее 4 баллов. Составить отчет о поступлении.

Составим таблицу с исходными данными:

Табель успеваемости.

Нужно общее количество баллов сравнить с проходным баллом. И проверить, чтобы по математике оценка была не ниже «4». В графе «Результат» поставить «принят» или «нет».

Введем формулу вида: . Логический оператор «И» заставляет функцию проверять истинность двух условий. Математическая функция «СУММ» используется для подсчета итогового балла.

Итог.

Функция ЕСЛИ позволяет решать многочисленные задачи, поэтому используется чаще всего.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Функция НЕ

Принимает в виде аргумента всего одно логическое значение и меняет его на противоположное, т.е. значение ИСТИНА она изменит на ЛОЖЬ и наоборот.

Таблица истинности функции И с применением функции НЕ:

НЕ(И()) ИСТИНА ЛОЖЬ
ИСТИНА ЛОЖЬ ИСТИНА
ЛОЖЬ ИСТИНА ИСТИНА

Таблица истинности функции ИЛИ с применением функции НЕ:

НЕ(ИЛИ()) ИСТИНА ЛОЖЬ
ИСТИНА ЛОЖЬ ЛОЖЬ
ЛОЖЬ ЛОЖЬ ИСТИНА

Синтаксис: =НЕ(логическое_значение)

Собираем таблицу истинности

Не обязательно собирать всё в одной ячейке. Можно сделать столбцы для промежуточных вычислений.

Для нашего примера _A ∨ B ∨ C ⊕ D

Используем Excel для построения таблицы истинности

Удобно.

Вы можете сохранить ссылку на эту страницу себе на компьютер в виде htm файла

Вы будете видеть наш сайт у себя в ленте

Нажмите “Подписаться”

Нажмите “Нравится” или напишите сообщение

Последние публикации

  • Статьи от: Автор
  • Рубрика: Блог
  • Сортировка: дата публикации по убыванию

Классический вход Windows 7

win_log3-150x150.jpg08.08.2021

Публикация 4 месяца назадКак это было в Windows XP Для входа в систему нужно указать: пользователь (login) пароль В Windows 7 сделали по умолчанию стандартный вход в систему Мышкой выбираем пользователя и вводим только пароль (если он установлен). Как вернуть классический вход в систему Windows 7 и зачем это нужно? Для работы на локальной машине – конечно удобнее стандартный вход. А вот если Вы подключаетесь к удаленной машине через RDP – то ввода только пароля недостаточно. Читаем статью RDP – удаленный рабочий стол Большое количество ботов со всего мира подберет Ваш пароль достаточно быстро (в логах будет по 5-10 попыток в секунду). Читаем…

(Читать полностью…)

Процессоры AMD FX и их «ядра»

fx-150x150.jpg15.12.2020

Публикация 12 месяцев назадНемного маркетинга в тему – ядра процессоров AMD FX и ядра процессоров Intel AMD FX (AM3+) – хорошие были процессоры. Но есть нюанс. AMD использовала хитрую терминологию – “ядра” и “модули”. Причем “ядра” – это собственно были потоки (“нити”), а “модули” – физические ядра процессора. Конечно, операционная система видела именно виртуальные ядра, число ядер в программе и на упаковке процессора совпадало – и пользователь был доволен: купил 8-ми ядерный процессор и в операционной системе он видит 8-ми ядерный процессор Формально AMD были правы, т.к. Hyperthreading (многопоточность) — технология от компании Intel.  А свою продукцию AMD…

(Читать полностью…)

Загадочная «маска подсети» — это просто

mask0-150x150.jpg08.12.2020

Публикация 12 месяцев назадМногие видели в Windows свойства адаптера сети при ручной настройке Многие даже понимают, что IP-адрес 192.168.1.1 – это запись в десятичной форме 32-х бит адреса IP v4 с разбивкой на оксеты (по 8 бит). А что такое “маска подсети”? Которая 255.255.255.0. И зачем она нужна? Посмотрим в таком же двоичном виде – легко видеть, что это 24 единицы подряд Это просто так айтишники шутят 🙂 Маска – это и есть маска, она “накладывается” на IP-адрес. Буквально. И далее используется логическое “И” 0 и 0 = 0 0 и 1 = 0 1 и 0 = 0 1 и 1 …

(Читать полностью…)

Вычисляем большие числа

googol-150x150.jpg04.12.2020

Публикация 12 месяцев назадСамое известное большое число googol – отсюда собственно название Google 10100 = это 1 единица и 100 нулей Хорошо. А например, 2512 – это сколько? Калькулятор Windows говорит, что это 1,3 * 10154 Тоже неплохо, да и больше чем googol на 54 порядка 🙂 А как такое число точно узнать? У нас обычно 64 бита  в ячейке памяти (разрядность 64), 2512 – это очевидно больше. Легко видеть, что в в двоичной системе это 513 разрядов = одна единица и 512 нулей 2512 = 1*2512 + 0*2511 + ….. + 0*21 +…

(Читать полностью…)

Как соединить два роутера проводом?

2_router-150x150.jpg13.10.2020

Публикация 1 год назадПредположим, у нас есть “Главный роутер”, который управляем всеми нашими устройствами PC. И еще есть: у “Главного роутера” второй WAN-порт бесхозный ADSL роутер Простой вопрос – как сделать резервирование интернета? Что бы при отсутствии основного интернета можно было подключить и использовать “Роутер ADSL”? Основная статья про сеть здесь Варианты в лоб: использовать только “Роутер ADSL” – но это придется к нему переподключать все конечные ПК и сетку Wi-Fi придется перестраивать для переподключения мобильных устройств Нехорошо 🙂 А как бы нам сделать так, что бы просто провод из LAN-порта “Роутера ADSL” включить в…

(Читать полностью…)

Как не надо устанавливать SSD M.2

m2_4-150x150.jpg17.09.2020

Публикация 1 год назадИногда вот такая жесть бывает при установке SSD M.2. Небольшой изгиб, так сказать. Основная статья про M.2 тут Интерфейс NVMe и разъемы M.2 и U.2 Как это получилось? Обычно так бывает при самостоятельной сборке ПК из новых комплектующих. SSD M.2 устанавливается под 45% в разъем на плате и потом прижимается винтиком, которые вкручивается в другой винтик на материнской плате. Но почему этот основной винтик  “пенек” может отсутствовать на материнской плате? Вот тут хорошо видно проблему 🙂 SSD может быть разной длины и…

(Читать полностью…)

Как набрать немецкие умляуты (umlaut) на обычной клавиатуре в России?

umlaut-150x150.jpg31.07.2020

Публикация 1 год назадБудем разбираться с немецкими умляутами Используем Alt-наборПервый и самый очевидный способ – на английской раскладке используем набор Alt+код на цифрой клавиатуре. На русской раскладке результат будет другой! Там еще есть эсцет – двойное ss (Alt 0223) – его тоже иногда относят к умляутам.Ä (Alt 0196) ä (Alt 0228)Ö (Alt 0214) ö (Alt 0246)Ü (Alt 0220) ü (Alt 0252)ẞ (нет кода) ß (Alt 0223)А что это за заглавная ẞ? Разве есть такая буква? Есть – читаем статью Заглавная немецкая буква эсцет ẞ Неудобно – для набора буквы надо 5 нажатий (Alt и 4 символа кода)Используем немецкую…

(Читать полностью…)

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...