Таблица функция в excel

Отображение функций в Excel с картинами и готовыми образцами их внедрения на практике. Вычислительные операции с формулами.

#1. СУММ

Синтаксис: =СУММ(число1;[число2];…)

число1 — обязательный аргумент.

Функция дает возможность найти сумму отдельных числовых значений, диапазонов, ссылок на ячейки с числовыми значениями или сумму всех этих 3-х видов. Часто используется в подбивании итоговых значений строк или столбцов при формировании отчетов.

Примеры использования

Допустим, у вас есть массив числовых значений и вам нужно посчитать сумму некоторых из них. Используя функцию СУММ, в области аргументов функции мы подставляем нужные ссылки на ячейки и получаем ответ — 312.

В кое-каких случаях в массивах не находятся значения, которые нужно так же просуммировать, и вместо ссылок можем добавить свои числа. Ответ в этом случае — 419.

image14.png

Так как функция работает не только с числовыми значениями, а и с целыми диапазонами, можно найти сумму всего диапазона.

image3.png

Можно не ограничивать себя в количестве значений, которые нужно просуммировать, а посчитать все значения в столбцах или строках. К примеру, просуммируем все значения в первых двух столбцах.

image8.png

Если в одной или нескольких ячейках диапазона окажется не числовое выражение, а текстовое, Excel будет приравнивать эти значения к нулю.

image17.png

Как создать Таблицу в Excel

В наличии имеется обычный диапазон данных о продажах.

Обычный диапазон данных

Для преобразования диапазона в Таблицу выделите любую ячейку и затем Вставка → Таблицы → Таблица

Создать таблицу Excel с ленты

Есть горячая клавиша Ctrl+T.

Появится маленькое диалоговое окно, где можно поправить диапазон и указать, что в первой строке находятся заголовки столбцов.

Создание таблицы Excel

Как правило, ничего не меняем. После нажатия Ок исходный диапазон превратится в Таблицу Excel.

Перед тем, как перейти к свойствам Таблицы, посмотрим вначале, как ее видит сам Excel. Многое сразу прояснится.

Интерфейс

Настраиваем панель быстрого доступа

Начнем с самого простого — добавления самых часто используемых опций на панель быстрого доступа. Чтобы сделать это, заходите в параметры Excel — «Настроить ленту» — и ищите в параметрах «Панель быстрого доступа».

Опции, перенесенные на панель быстрого доступа, будут доступны при работе со всеми вашими книгами Excel (хотя можно ее настроить и отдельно для любой книги). Так что если пользуетесь какими-то командами и инструментами постоянно — добавляйте их туда.

Другой вариант — просто щелкнуть по инструменту на ленте правой кнопкой мыши и нажать «Добавить…»:

Перемещаемся по ленте без мышки

Нажмите на Alt. На ленте инструментов появились цифры и буквы — у каждого инструмента на панели быстрого доступа и у каждой вкладки на ленте соответственно:

Нажмите на клавиатуре любую из букв — попадете на соответствующую вкладку на ленте, а там каждый инструмент в свою очередь тоже будет подписан. Так можно быстро вызвать нужные опции, не трогая мышку.

Соединить текст из разных ячеек

Иногда надо быстро собрать данные из разных ячеек в одной. Поочередно копировать долго и неудобно, поэтому лучше использовать формулу с амперсандом — знаком «&».

Для этого выберите ячейку, в которой хотите соединить информацию, и перечислите через & номера нужных ячеек.

Соединение текста экономит скорее время, чем деньги, но при правильном подходе это легко конвертировать

Подобрать значения для нужного результата

Эксель помогает не только собирать данные, но и планировать достижение целей. Например, если вы ведете в программе бюджет, можно задать сумму, которую планируете накопить за год, и в одно действие посчитать, насколько нужно уменьшить траты на кофе.

Для этого на вкладке «Данные» надо выбрать «Анализ „Что если“», с помощью функции «Подбор параметра» задать целевое значение и выбрать ячейку, которую нужно изменить для получения желаемой цифры.

Эта же формула работает в обратную сторону: если вы решили открыть магазин и рассчитываете на определенную прибыль, то функция покажет, сколько товаров и по какой цене нужно продавать.

«Подбор параметра» подойдет и для составления бизнес-плана. Введите желаемую прибыль и посчитайте, сколько единиц товара и с какой накруткой нужно продавать

Вставка функции в таблицу

Теперь давайте разберемся с тем, как в Excel задать формулу, то есть добавить ее в таблицу, обеспечив вычисление определенных значений. Вы можете писать функции как самостоятельно, объявляя их название после знака «=», так и использовать графическое меню, переход к которому осуществляется так, как это было показано выше. В Комьюнити уже есть статья «Как вставить формулу в Excel», поэтому я рекомендую нажать по выделенной ссылке и перейти к прочтению полезного материала.Использование графического меню для работы с формулами в Excel

Как показать сразу несколько скрытых листов в Excel?

Василий18:50:00 Add Comment

При работе с большими книгами в Excel, часто возникает необходимость скрыть лишние листы, что бы они не мешались в работе. Но что делать, ес…

Далее…

#5. ОКРУГЛ

Синтаксис: =ОКРУГЛ(число; число_разрядов)

число — аргумент.

число_разрядов — до какого разряда округляется число.

Функция ОКРУГЛ применяется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение согласно математическому правилу округления.

К примеру, для округления числа 2,57525 до 2-х символов после запятой можно ввести формулу =ОКРУГЛ(2,57525;2), которая вернет значение 2,58. Эта функция часто используется при построении балансовых и других видов отчетности.

Дата и время

За любой датой в Excel скрывается целое число. Датой его делает формат.

Аналогично со временем: одна единица — это день, а часть единицы (число от 0 до 1) — время, то есть часть дня.

Это не значит, что так имеет смысл вводить даты и время в ячейки, вводите их в любом из стандартных форматов — Excel сразу отформатирует их как даты:

ДД.ММ.ГГГГ

ДД/ММ/ГГГГ

ГГГГ-ММ-ДД

С датами можно производить операции вычитания и сложения.

Вычесть из одной даты другую, чтобы получить разницу в днях (результатом вычитания будет число — количество дней.

Прибавить к дате число — и получить дату, которая наступит через соответствующее количество дней.

8) ПРОПИСН

Функция ПРОПИСН делает все буквы в тексте прописными.

Синтаксис

Формула функции:

=ПРОПИСН(текст)

«Текст» здесь – текстовый элемент или ссылка на ячейку.

Пример

Строчные буквы преобразовались в прописные в мгновение ока

Растягивание функций и обозначение константы

Работа с формулами в Эксель подразумевает и выполнение более сложных действий, связанных с заполнением строк всей таблицы и связыванием нескольких разных значений. В этом разделе статьи я объединю сразу две разных темы, поскольку они тесно связаны между собой и обе упрощают взаимодействие с открытым в программе проектом.

Для начала остановимся на растягивании функции. Для этого вам необходимо ввести ее в одной ячейке и убедиться в получении корректного результата. Затем зажмите точку в правом нижнем углу ячейки и проведите вниз.

Растягивание функции для работы с формулами в Excel

В итоге вы должны увидеть, что функция растянулась на выбранный диапазон, а значения в ней подставлены автоматически. Так, изначальная функция имела вид =B2*C2, но после растягивания вниз последующие значения подставились автоматически (от B3*C3 до B13*C13, что видно на следующем изображении). Точно так же растягивание работает с СУММ и другими простыми формулами, где используется несколько аргументов.

Результат растягивания для работы с формулами в Excel

Константа, или абсолютная ссылка, – обозначение, закрепляющее конкретную ячейку, столбец или строку, чтобы при растягивании функции выбранное значение не заменялось, а оставалось таким же.

Сначала разберемся с тем, как задать константу. В качестве примера сделаем постоянной и строку, и столбец, то есть закрепим ячейку. Для этого поставьте знак «$» как возле буквы, так и цифры ячейки, чтобы в результате получилось такое написание, как показано на следующем изображении.

Объявление константы для работы с формулами в Excel

Растяните функцию и обратите внимание на то, что постоянное значение таким же и осталось, то есть произошла замена только первого аргумента. Сейчас это может показаться сложным, но стоит вам самостоятельно реализовать подобную задачу, как все станет предельно ясно, и в будущем вы вспомните, что для выполнения конкретных задач можно использовать подобную хитрость.

Растягивание функции с константой для работы с формулами в Excel

В закрепление темы рассмотрим три константы, которые можно обозначить при записи функции:

  • $В$2 – при растяжении либо копировании остаются постоянными столбец и строка.

  • B$2 – неизменна строка.

  • $B2 – константа касается только столбца.

#7. ВПР

Синтаксис: =ВПР(искомое_значение; таблица; номер_столбца; [интервальный_просмотр])

искомое_значение — значение, которое необходимо найти в столбце с данными. Аргументы бывают числовыми и текстовыми. Искомое значение должно находиться в крайнем левом столбце диапазона ячеек указанной таблицы.

таблица — ссылка на диапазон ячеек. В левом столбце выполняется поиск искомого значения, а из столбцов правее выводится соответствующее значение. Левый столбец еще называют ключевым. Если в таблице не окажется искомого значения, вернется ошибка #Н/Д.

номер_столбца — номер столбца таблицы, согласно которому нужно вывести результат.

[интервальный_просмотр] — необязательный аргумент. Принимает два значения: ИСТИНА и ЛОЖЬ. ИСТИНА устанавливается по умолчанию, и функция предполагает, что левый столбец таблицы отсортирован по возрастанию в алфавитном порядке. Если в этом аргументе — ИСТИНА, функция ищет ближайшее к искомому или совпадающее с ним значение, ЛОЖЬ — ищет стопроцентное совпадение с искомым значением.

Это функция, которая упростит работу с большими массивами данных и несколькими таблицами. Будет полезной, если нужно подтянуть соответствующий критерию столбец из другой таблицы (например, группа, категория).

Пример

Вернемся к нашей таблице из пункта 6 (ЕСЛИ). Предположим, что каждому предмету покупки присвоили группу, к которой он относится (овощи, фрукты, кондитерские изделия и др.), и у нас есть справочник соответствий, но в другой таблице. В массивах данных, состоящих из тысяч строк, делать это вручную очень долго, а ВПР справится за долю секунды.

image11.png

В ячейке G2 пишем формулу: =ВПР(A2;$L$2:$M$78;2;ЛОЖЬ). Обязательно ставим знаки фиксации диапазона $ — в случае их отсутствия при протягивании формулы вниз диапазон ячеек таблицы также будет смещаться вниз вместе с искомым значением.

Как прочитать формулу простым языком: найти значение из ячейки A2 в левом столбце таблицы L2:M78 и вывести соответствующее найденному искомому_значению выражение из столбца 2 этой таблицы, при этом искомое значение должно совпадать с данными в левом столбце таблицы (аргумент ЛОЖЬ).

image6.png

Протягиваем формулу вниз — и выводится результат.

image16.png

15) СЖПРОБЕЛЫ

Данная функция удаляет все лишние пробелы между словами.

Синтаксис

Формула функции проста: =СЖПРОБЕЛЫ(номер_ячейки)

Пример

Функция позволяет убрать лишние пробелы в тексте

Функция простая и полезная. Единственный минус состоит в том, что она не различает границ слов, и если внутри него стоят пробелы, функция этого не поймет и не удалит их.

Функция не распознает пробелы внутри слов

#10. СЦЕПИТЬ

Синтаксис: =СЦЕПИТЬ(текст1;[текст2];[текст3];…)

текст1 — обязательный аргумент.

Для объединения значений из разных ячеек в одну используется функция СЦЕПИТЬ. Также можно применять аналог — & (амперсанд). Функция часто используется для объединения данных с нескольких столбцов.

Пример

Допустим, у нас есть таблица сотрудников с разделенными ФИО, должностью и возрастом, а в отчете нужно отобразить все эти значения в одной ячейке. Для выполнения этой задачи используем функцию так:

image10.png

Хотите получать дайджест статей?

Одно письмо с лучшими материалами за неделю. Подписывайтесь, чтобы ничего не упустить.

Спасибо за подписку!

Последние материалы

img-mascot-619faf0bec82a355501337.jpg

Как появилась идея говорящих драже M&M’s и в чем успех английского капитана Моргана.

img-liski-619f751aeadcc188867888.jpg

Рассказываем, как диверсифицировать риски в бизнесе.

img-alkhimovich-619e600e7da7f353639925.jpg

6 способов завоевать авторитет в команде — от топ-менеджера с 10-летним опытом (Luxoft).

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...