Столбец в Эксель

Синтаксис: СТОЛБЕЦ([ссылка])

Описание и синтаксис функции

Функция с параметром: = СТОЛБЕЦ (С3) возвращает значение 3, т.к. (C) является третьим по счету.

Аргумент «ссылка» необязательный. Это может быть ячейка или диапазон, для которого нужно получить номер столбца.

Аргумент – ссылка на ячейку:

Ссылка на ячейку.

Функция выдала номер колонки для этой ячейки.

Аргумент опущен:

Аргумент опущен.

Функция вернула номер столбца, в котором находится.

Аргумент – вертикальный диапазон ячеек:

Вертикальный диапазон ячеек.

Функция вернула номер столбца, в котором расположен диапазон.

Аргумент – горизонтальный диапазон ячеек:

Горизонтальный диапазон ячеек.

Функция СТОЛБЕЦ вернула номер крайнего левого столбца (А) в указанном диапазоне. Если выделить формулу в строке формул и нажать кнопку F9, то программа выдаст все номера столбцов заданного диапазона.

В массиве.

Но при нажатии кнопки Enter в ячейке с формулой отобразится только номер крайнего левого столбца.

Чтобы на листе появились номера всех столбцов диапазона, который является аргументом функции СТОЛБЕЦ, нужно использовать формулу массива. Выделяем такое количество ячеек, сколько элементов входит в горизонтальный диапазон. Вводим формулу и нажимаем сочетание кнопок Ctrl + Shift + Enter.

Аргумент – ссылка на горизонтальный массив:

Ссылка на горизонтальный массив.

Формула вернула номера столбцов в виде горизонтального массива.

В качестве аргумента нельзя применять ссылки на несколько областей.

В качестве ссылки указан адрес одной ячейки

Если в качестве ссылки указан адрес одной ячейки, то функция вернет номер столбца этой ячейки

=СТОЛБЕЦ(B1) вернет 2, =СТОЛБЕЦ(F2) вернет 6. Чтобы убедиться, что номер столбца F действительно 6 включите стиль ссылок R1C1 ( )

Если требуется задать название столбца через буквенное обозначение, то используйте формулу

=СТОЛБЕЦ(ДВССЫЛ(“F”&3))

Вставка столбца

В Экселе существует несколько способов вставить столбец на лист. Большинство из них довольно просты, но начинающий пользователь может не сразу со всеми разобраться. Кроме того, существует вариант автоматического добавления строк справа от таблицы.

Вставка через панель координат

Одним из самых простых способов вставки является операция через горизонтальную панель координат Excel.

  1. Кликаем в горизонтальной панели координат с наименованиями колонок по тому сектору, слева от которого нужно вставить столбец. При этом колонка полностью выделяется. Кликаем правой кнопкой мыши. В появившемся меню выбираем пункт «Вставить».

Dobavlenie-stolbtsa-cherez-panel-koordinat-v-Microsoft-Excel.png

После этого слева от выделенной области тут же добавляется новый столбец.

Stolbets-dobavlen-cherez-panel-koordinat-v-Microsoft-Excel.png

Добавление через контекстное меню ячейки

Можно выполнить данную задачу и несколько по-другому, а именно через контекстное меню ячейки.

  1. Кликаем по любой ячейке, находящейся в столбце справа от планируемой к добавлению колонки. Кликаем по этому элементу правой кнопкой мыши. В появившемся контекстном меню выбираем пункт «Вставить…».

Vstavka-stolbtsa-cherez-kontekstnoe-menyu-v-Microsoft-Excel.png

На этот раз добавление не происходит автоматически. Открывается небольшое окошко, в котором нужно указать, что именно пользователь собирается вставить:

  • Столбец;
  • Строку;
  • Ячейку со сдвигом вниз;
  • Ячейку со сдвигом вправо.

Переставляем переключатель в позицию «Столбец» и жмем на кнопку «OK».

Vyibor-tipa-dobavleniya-yacheek-v-Microsoft-Excel.png

После этих действий колонка будет добавлена.

Stolbets-dobavlen-cherez-kontekstnoe-menyu-v-Microsoft-Excel.png

Кнопка на ленте

Вставку столбцов можно производить, используя специальную кнопку на ленте.

  1. Выделяем ячейку, слева от которой планируется добавить столбец. Находясь во вкладке «Главная», кликаем по пиктограмме в виде перевернутого треугольника, расположенного около кнопки «Вставить» в блоке инструментов «Ячейки» на ленте. В открывшемся меню выбираем пункт «Вставить столбцы на лист».

Vstavka-stolbtsa-cherez-knopku-na-lente-v-Microsoft-Excel.png

После этого колонка будет добавлена слева от выделенного элемента.

Stolbets-dobavlen-v-Microsoft-Excel.png

Полезные примеры функции СТОЛБЕЦ в Excel

Формула с использованием функции выдает массив последовательных чисел. Эту особенность можно применить для решения других задач.

Например, рассчитаем значение выражения 1 + ½ + 1/3. Используем формулу: =СУММПРОИЗВ(1/СТОЛБЕЦ(A2:C2)).

СУММПРОИЗВ.

Выполним более сложные манипуляции с числовым рядом: найдем сумму значений от 1 до 1/n^3, где n = 6. Формула расчета: =СУММПРОИЗВ(1/СТОЛБЕЦ(A9:F9)^3).

Формула расчета.

Чаще всего данную функцию используют совместно с функцией ВПР. Задача первой функции – указать номер столбца возвращаемых значений. Такое совмещение удобно при работе с огромными таблицами. Например, пользователь помещает возвращаемые данные в табличку с такой же, как в исходной таблице, последовательностью столбцов. Причем обе таблицы достаточно широкие.

Напомним, что ВПР ищет заданное значение в крайнем левом столбце диапазона и возвращает значение из другого столбца в той же строке. Говоря техническим языком, ВПР находит в базе данных уникальный идентификатор и извлекает связанную с ним информацию.

Аргументы функции ВПР: искомое значение, массив данных для анализа, номер столбца, интервальный просмотр (точный или приблизительный поиск). Сам номер можно задать с помощью такой формулы: =ВПР(8;A1:C10;СТОЛБЕЦ(C1);ИСТИНА).

ВПР.

При работе с широкими таблицами можно просто копировать функцию ВПР по горизонтали. В этом случае номера столбцов автоматически пересчитываются – табличка заполняется.

Нужна корректировка номера– прибавляем или отнимаем определенную цифру или рассчитанное с помощью какой-либо функции значение. Например,

Пример.

Функция СТОЛБЕЦ должна вычесть 1 из номера колонки C. Поэтому функция ВПР возвращает значение не из третьего, а из второго столбца девятой строки.

Теперь проиллюстрируем, как работает многоразовое копирование без необходимости в ручной правке. Сначала в формуле закрепим ссылки на таблицу (кнопка F4). Скопируем формулу ВПР поперек столбцов – номер меняется автоматически (функция СТОЛБЕЦ сдвигается вместе с другими ссылками).

Автоматически.

Достаточно элегантное решение, позволяющее править формулы в автоматическом режиме.

Пример

Примеры функции СТОЛБЕЦ

Нужна дополнительная помощь?

Пример функции СТОЛБЕЦ

Для примера укажем в качестве ссылки адрес произвольной ячейки (например, D7), в результате выполнения формулы СТОЛБЕЦ получаем значение 4 (т.е. номер столбца D):

Пример № 1 использования функции СТОЛБЕЦ

Пример № 1 использования функции СТОЛБЕЦ

Если не указывать ссылку в качестве аргумента функции, то Excel автоматически предполагает, что это ссылка на ячейку, в которой введена формула.
Другими словами, если формула СТОЛБЕЦ введена в ячейку B2, то в результате выполнения функции получим значение 2 (т.е. номер столбца B):

Пример № 2 использования функции СТОЛБЕЦ

Пример № 2 использования функции СТОЛБЕЦ

Удачи вам и до скорых встреч на страницах блога Tutorexcel.ru!

3-D сумма, или работаем с несколькими листами рабочей книги Excel.

Чтобы подсчитать цифры из одинаковой формы диапазона на нескольких листах, вы можете записывать координаты данных специальным синтаксисом, называемым «3d-ссылка».

Предположим, на каждом отдельном листе вашей рабочей книги имеется таблица с данными за неделю. Вам нужно свести все это в единое целое и получить свод за месяц. Для этого будем ссылаться на четыре листа.

Посмотрите на этом небольшом видео, как применяются 3-D формулы.

Как видите, у нас имеется 4 одинаковых таблицы. Стандартный метод нахождения выручки за месяц –

=СУММ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

В качестве аргументов перечисляем диапазоны данных.

А вот 3D-метод:

=СУММ(неделя1:неделя4!B2:B8)

Мы указываем программе, что нужно произвести вычисления с ячейками B2:B8, находящимися на листах неделя1, неделя2, неделя3, неделя4. Здесь номер листа последовательно увеличивается на 1.

Важное замечание. Вы можете пользоваться 3D-ссылками и в других случаях. К примеру, выражение

=СРЗНАЧ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

найдет среднее значение однодневной выручки за месяц.

Формирование массива последовательных чисел

Записав формулу =СТОЛБЕЦ(A26:D26) мы сформируем массив последовательных чисел , который можно использовать в других задачах. Например, найдем сумму числового ряда 1+1/2+1/3+1/4+1/5+1/6+1/7 с помощью формулы =СУММПРОИЗВ(1/СТОЛБЕЦ(A1:G1))

Сумму ряда от 1 до 1/n^2, где n = 7 можно вычислить так: =СУММПРОИЗВ(1/(СТОЛБЕЦ(A1:G1)^2))

Синтаксис

=COLUMN([reference]) – английская версия

=СТОЛБЕЦ([ссылка]) – русская версия

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...