Статистические функции в Excel. Описание всех функций, как их использовать

Функция AVERAGE (СРЗНАЧ) в Excel используется для вычисления среднего арифметического из заданного диапазона данных.

Описание

Возвращает среднее арифметическое аргументов. Например, если диапазон A1:A20 содержит числа, формула =СПБ(A1:A20) возвращает среднее из этих чисел.

Первый способ как рассчитать среднее значение в Excel.

Если выделить диапазон ячеек, по которым нужно рассчитать среднее значение, то Excel, автоматически рассчитает среднее значение по этому диапазону и покажет его в правом нижнем углу окна программы. Ехсel сделает это по умолчанию, без каких-либо дополнительных действий со стороны пользователя ПО.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

Описание

Microsoft Excel функция СРЗНАЧ возвращает среднее (среднее арифметическое) представленных чисел.
Функция СРЗНАЧ – это встроенная в Excel функция, которая относится к категории статистических функций.
Её можно использовать как функцию рабочего листа (WS) в Excel.
Как функцию рабочего листа, функцию СРЗНАЧ можно ввести как часть формулы в ячейку рабочего листа.

Синтаксис

СРЗНАЧ(число1;[число2];…)

Аргументы функции СРЗНАЧ описаны ниже.

  • Число1    Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

  • Число2…    Необязательный. Дополнительные числа, ссылки на ячейки или диапазоны, для которых нужно вычесть среднее значение, не более 255.

Замечания

  • Аргументы могут быть числами, именами или ссылками на диапазоны или ячейки, содержащие числа.

  • Логические значения и текстовые представления чисел, которые непосредственно введите в список аргументов, не учитываются.

  • Если аргумент является ссылкой на диапазон или ячейку, содержащую текст или логические значения, или ссылкой на пустую ячейку, то такие значения игнорируются; однако ячейки, которые содержат нулевые значения, учитываются.

  • Аргументы, являющиеся значениями ошибок или текстом, которые не могут быть преобразованы в числа, вызывают ошибки.

  • Если логические значения и текстовые представления чисел необходимо учитывать в расчетах, используйте функцию СРЗНАЧА.

  • Если требуется вычислить среднее значение только для тех значений, которые удовлетворяют определенным критериям, используйте функцию СРЗНАЧЕСЛИ или СРЗНАЧЕСЛИМН.

Примечание: Функция СРЗНАЧ вычисляет среднее значение, то есть центр набора чисел в статистическом распределении. Существует три наиболее распространенных способа определения среднего значения, описанных ниже.

  • Среднее значение — это среднее арифметическое, которое вычисляется путем сложения набора чисел с последующим делением полученной суммы на их количество. Например, средним значением для чисел 2, 3, 3, 5, 7 и 10 будет 5, которое является результатом деления их суммы, равной 30, на их количество, равное 6.

  • Медиана — это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана. Например, медианой для чисел 2, 3, 3, 5, 7 и 10 будет 4.

  • Мода — это число, наиболее часто встречающееся в данном наборе чисел. Например, модой для чисел 2, 3, 3, 5, 7 и 10 будет 3.

При симметричном распределении множества чисел все три значения центральной тенденции будут совпадать. При ассиметричном распределении множества чисел они могут отличаться.

Совет: При вычислении средних значений ячеек следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если в диалоговом окне Параметры Excel настольного приложения Excel снят флажок Показывать нули в ячейках, которые содержат нулевые значения. Если этот флажок установлен, пустые ячейки игнорируются, но нулевые значения учитываются.

Местонахождение флажка Показывать нули в ячейках, которые содержат нулевые значения

  • Откройте вкладку Файл , а затем нажмите кнопку Параметры и в категории Дополнительно найдите группу Показать параметры для следующего листа.

Применение

  • Excel для Office 365, Excel 2019, Excel 2016, Excel 2013, Excel 2011 для Mac, Excel 2010, Excel 2007, Excel 2003, Excel XP, Excel 2000

#5. ОКРУГЛ

Синтаксис: =ОКРУГЛ(число; число_разрядов)

число — аргумент.

число_разрядов — до какого разряда округляется число.

Функция ОКРУГЛ применяется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение согласно математическому правилу округления.

К примеру, для округления числа 2,57525 до 2-х символов после запятой можно ввести формулу =ОКРУГЛ(2,57525;2), которая вернет значение 2,58. Эта функция часто используется при построении балансовых и других видов отчетности.

#6. ЕСЛИ

Синтаксис: =ЕСЛИ (логическое_выражение;значение_если_истина;значение_если_ложь)

логическое_выражение — условие, выполнение которого проверяет оператор.

значение_если_истина — в случае, если условие окажется правдивым, будет возвращено это значение.

значение_если_ложь — в случае, если условие окажется неправдивым, будет возвращено это значение.

Эта функция одна из самых известных в работе с Эксель. В ней проверяются числа и/или текст, функции, формулы. Когда значения отвечают заданному условию, появляется запись из поля “значение_если_истина”, не отвечают — “значение_если_ложь”. Часто используется для распределения выражений на категории, группы.

Функция поддерживает использование операторов сравнения: = (равно), < (меньше), <= (меньше или равно), > (больше), >= (больше или равно), <> (не равно). Также часто используют эту функцию в связке с логическими операторами И, ИЛИ. Рассмотрим несколько примеров.

Пример 1

Предположим, что у нас есть таблица стоимости продуктов питания за 1 кг (л), и задача заключается в том, чтобы разбить товары на две группы в зависимости от цены:

– до 500

– больше 500

Для решения этой задачи используется функция ЕСЛИ.

image7.png

В ячейке E2 следующая формула: =ЕСЛИ(D2<=500;”до 500″;”больше 500″). Она расшифровывается так: если в указанной ячейке число будет меньше или равно 500 (1 на скриншоте), тогда функция должна вернуть текстовое выражение “до 500” (2 на скриншоте), если оно окажется другим — “больше 500” (3 на скриншоте).

Протянем эту формулу вниз и проверим работоспособность.

image15.png

Пример 2

Предположим, что в таблице выше нам необходимо каждому товару присвоить категорию по цене: “высокая стоимость” и “низкая стоимость”.

image13.png

В ячейке F2 была прописана следующая формула: =ЕСЛИ(E2=”до 500″;”низкая стоимость”;”высокая стоимость”). Расшифровка: если в указанной ячейке текстовое значение равняется “до 500”, тогда функция должна вернуть текстовое выражение “низкая стоимость”, если оно окажется другим — “высокая стоимость”.

Обратите внимание: когда проверяете условия на текстовое значение, это значение в кавычках необходимо брать в еще одни кавычки. Посмотрим на результат, протянув формулу до конца таблицы.

image15.png

Скачайте примеры для функции СРЗНАЧ

После статьи Вы можете скачать файл Excel с несколькими примерами использования формулы вычисления среднего значения. Рассмотрены указанные в таблице выше примеры, на основе которых несложно понять принципы работы СРЗНАЧ в различных случаях.

На основе наших примеров Вы можете создать свои собственные для закрепления материала. Если Вы обнаружите интересные случаи использования рассмотренной функции Эксель, поделитесь ими в комментариях.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Данные

10

15

32

7

9

27

2

Формула

Описание

Результат

=СРЗНАЧ(A2:A6)

Среднее значение чисел в ячейках A2–A6.

11

=СРЗНАЧ(A2:A6;5)

Среднее значение чисел в ячейках A2–A6 и числа 5.

10

=СРЗНАЧ(A2:C2)

Среднее значение чисел в ячейках A2–C2.

19

Нужна дополнительная помощь?

#7. ВПР

Синтаксис: =ВПР(искомое_значение; таблица; номер_столбца; [интервальный_просмотр])

искомое_значение — значение, которое необходимо найти в столбце с данными. Аргументы бывают числовыми и текстовыми. Искомое значение должно находиться в крайнем левом столбце диапазона ячеек указанной таблицы.

таблица — ссылка на диапазон ячеек. В левом столбце выполняется поиск искомого значения, а из столбцов правее выводится соответствующее значение. Левый столбец еще называют ключевым. Если в таблице не окажется искомого значения, вернется ошибка #Н/Д.

номер_столбца — номер столбца таблицы, согласно которому нужно вывести результат.

[интервальный_просмотр] — необязательный аргумент. Принимает два значения: ИСТИНА и ЛОЖЬ. ИСТИНА устанавливается по умолчанию, и функция предполагает, что левый столбец таблицы отсортирован по возрастанию в алфавитном порядке. Если в этом аргументе — ИСТИНА, функция ищет ближайшее к искомому или совпадающее с ним значение, ЛОЖЬ — ищет стопроцентное совпадение с искомым значением.

Это функция, которая упростит работу с большими массивами данных и несколькими таблицами. Будет полезной, если нужно подтянуть соответствующий критерию столбец из другой таблицы (например, группа, категория).

Пример

Вернемся к нашей таблице из пункта 6 (ЕСЛИ). Предположим, что каждому предмету покупки присвоили группу, к которой он относится (овощи, фрукты, кондитерские изделия и др.), и у нас есть справочник соответствий, но в другой таблице. В массивах данных, состоящих из тысяч строк, делать это вручную очень долго, а ВПР справится за долю секунды.

image11.png

В ячейке G2 пишем формулу: =ВПР(A2;$L$2:$M$78;2;ЛОЖЬ). Обязательно ставим знаки фиксации диапазона $ — в случае их отсутствия при протягивании формулы вниз диапазон ячеек таблицы также будет смещаться вниз вместе с искомым значением.

Как прочитать формулу простым языком: найти значение из ячейки A2 в левом столбце таблицы L2:M78 и вывести соответствующее найденному искомому_значению выражение из столбца 2 этой таблицы, при этом искомое значение должно совпадать с данными в левом столбце таблицы (аргумент ЛОЖЬ).

image6.png

Протягиваем формулу вниз — и выводится результат.

image16.png

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...