Среднее арифметическое в excel: как посчитать, примеры по условию

Примеры работы функций СРЗНАЧ и СРЗНАЧА, а также обзор их особенностей и отличий между собой. К какой категории относится функция СРЗНАЧ и СРЗНАЧА?

Примеры использования функции СРЗНАЧ в Excel

Функция СРЗНАЧ относится к группе «Статистические». Поэтому для вызова данной функции в Excel необходимо выбрать инструмент: «Формулы»-«Библиотека функций»-«Другие функции»-«Статистические»-«СРЗНАЧ». Или вызвать диалоговое окно «Вставка функции» (SHIFT+F3) и выбрать из выпадающего списка «Категория:» опцию «Статистические». После чего в поле «Выберите функцию:» будет доступен список категории со статистическими функциями где и находится СРЗНАЧ, а также СРЗНАЧА.

Статистические.

Если есть диапазон ячеек B2:B8 с числами, то формула =СРЗНАЧ(B2:B8) будет возвращать среднее значение заданных чисел в данном диапазоне:

СРЗНАЧ.

Синтаксис использования следующий: =СРЗНАЧ(число1; [число2]; …), где первое число обязательный аргумент, а все последующие аргументы (вплоть до числа 255) необязательны для заполнена. То есть количество выбранных исходных диапазонов не может превышать больше чем 255:

Аргументы функции.

Аргумент может иметь числовое значение, быть ссылкой на диапазон или массив. Текстовое и логическое значение в диапазоне полностью игнорируется.

Аргументы функции СРЗНАЧ могут быть представлены не только числами, но и именами или ссылками на конкретный диапазон (ячейку), содержащий число. Учитывается логическое значение и текстовое представление числа, которое непосредственно введено в список аргументов.

Если аргумент представлен ссылкой на диапазон (ячейку), то его текст или логическое значение (ссылка на пустую ячейку) игнорируется. При этом ячейки, которые содержат нуль, учитываются. Если аргумент содержит ошибки или текст, который не может быть преобразован в число, то это приводит к общей ошибке. Для учета логических значений и текстового представления чисел необходимо в расчетах использовать функцию СРЗНАЧА, о которой пойдет разговор дальше.

Не числовые типы.

Результат выполнения функции в примере на картинке ниже – это число 4, т.к. логические и текстовые объекты игнорируются. Поэтому:

(5 + 7 + 0 + 4) / 4 = 4

При вычислениях средних значений необходимо учитывать разницу между пустой ячейкой и ячейкой, содержащей нулевое значение, особенно если в диалоговом окне Excel снят флажок «Показывать нули в ячейках, которые содержат нулевые значения». Когда флажок установлен, пустые ячейки игнорируются, а нулевые значения нет. Чтобы снять или установить этот флаг необходимо открыть вкладку «Файл», далее нажать на «Параметры» и выбрать в категории «Дополнительно» группу «Показать параметры для следующего листа», где возможно установить флажок:

Параметры Excel.

Результаты еще 4-х задач сведены в таблицу ниже:

Таблица примеров.

Как видно на примере, в ячейке A9 функция СРЗНАЧ имеет 2 аргумента: 1 – диапазон ячеек, 2 – дополнительное число 5. Так же могут быть указаны в аргументах и дополнительные диапазоны ячеек с числами. Например, как в ячейке A11.

Описание

Возвращает среднее арифметическое аргументов. Например, если диапазон A1:A20 содержит числа, формула =СПБ(A1:A20) возвращает среднее из этих чисел.

Информация в строке состояния

Пожалуй, это самый легкий и быстрый способ определения среднего значения. Для этого достаточно выделить диапазон, содержащий от двух ячеек и более, и среднее значение по ним сразу же отобразится в строке состояния программы.

Выделенные ячейки строки в Эксель

Если данная информация недоступна, скорее всего, соответствующий пункт выключен в настройках. Чтобы обратно его включить, щелкаем правой кнопкой мыши по строке состояния, в открывшемся списке проверяем наличие флажка напротив строки “Среднее”. Поставить его в случае необходимости можно простым щелчком левой кнопки мыши.

Среднее значение по выделенным ячейкам в строке состояния Эксель

Первый способ как рассчитать среднее значение в Excel.

Если выделить диапазон ячеек, по которым нужно рассчитать среднее значение, то Excel, автоматически рассчитает среднее значение по этому диапазону и покажет его в правом нижнем углу окна программы. Ехсel сделает это по умолчанию, без каких-либо дополнительных действий со стороны пользователя ПО.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

Определение среднего значения чисел в Excel

   17.02.2017

как найти среднее значение в excel
Excel предсталяет собой табличный процессор. Его можно использовать для создания разнообразных отчетов. В данной программе очень удобно производить разные вычисления. Многие не используют и половину возможностей Excel.

Найти средние значение чисел может понадобиться в школе, а также во время работы. Классическим способ определения среднего арифметического без использования программ заключается в складывании всех чисел, а затем полученную сумму нужно разделить на количество слагаемых. Если числа достаточно крупные или для отчетности необходимо выполнить операцию много раз, вычисления могут занять много времени. Это нерациональная трата сил и времени, намного лучше воспользоваться возможностями Excel.

В чем проблема?

Под средним значением чаще всего подразумевается среднее арифметическое, которое очень сильно варьируется под воздействием единичных фактов или событий. И вы не получите реального представления о том, как именно распределены значения, которые вы изучаете.

Давайте обратимся к классическому примеру со средней зарплатой.

В какой-то абстрактной компании работает десять сотрудников. Девять из них получают зарплату около 50 000 рублей, а один 1 500 000 рублей (по странному совпадению он же является генеральным директором этой компании).

Выборка зарплат

Средним значением в данном случае будет 195 150 рублей, что согласитесь, неправильно.

Расчет среднего значения

Когда среднее значение нужно не только определить, но и зафиксировать в отдельной выбранной для этого ячейке, можно использовать несколько методов. Ниже мы подробно рассмотрим каждый из них.

Синтаксис

СРЗНАЧ(число1;[число2];…)

Аргументы функции СРЗНАЧ описаны ниже.

  • Число1    Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

  • Число2…    Необязательный. Дополнительные числа, ссылки на ячейки или диапазоны, для которых нужно вычесть среднее значение, не более 255.

Об этой статье

Эту страницу просматривали 23 792 раза.

Видео работы функции

Работа с часто используемыми функциями (Автосумма)

Третий способ как рассчитать среднее значение в Excel.

Воспользуемся кнопкой вызова функции: Вставить функцию.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

Выбираем ячейку, в которой должно появиться среднее значение, которое нам нужно рассчитать. Например, в ячейки Н3. После нажатия на кнопку Вставить функцию, появиться диалоговое окно Вставка функции, в котором будет перечень 10 недавно использовавшихся функций, в числе которых может быть интересующее нас функция: СРЗНАЧ. Если данной функции в перечне не будет, нужно воспользоваться поиском. В поле поиска нужно прописать СРЗНАЧ и нажать Найти.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

Нажимаем ОК. Появляется диалоговое окно Аргументы функции.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

В поле Число 1, нужно внести диапазон ячеек, по которым нужно рассчитать среднее значение. Становимся курсором на поле Число 1 и выделяем нужный нам диапазон ячеек.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

Нажимаем ОК. Получаем среднее значение по заданному диапазону ячеек.

В поле Число 2, можно добавить еще один диапазон ячеек. И тогда функция будет считать среднее по двум диапазонам. Причем, если добавить диапазон в поле Число 2, то в диалоговом окне Аргументы функции появиться еще одно поле: Число 3. В которое так же можно добавить диапазон ячеек. Соответственно, если добавить диапазон в поле Число 3, появиться поле Число 4 и так далее.

Среднее значение. Функция СРЗНАЧ в MS Excel. Описание и примеры

В поля Число 1, Число 2, Число 3 и т.д., можно, в место диапазона ячеек,  указывать отдельные ячейки и рассчитывать по ним среднее значение. Ячейки при этом могут находится в разных частях Листа.

Диапазоны ячеек или отдельные ячейки, для подсчета среднего значения, могут находиться на разных Листах книги. Само искомое среднее значение, так же может находиться на отдельном листе от исходных данных.  Алгоритм работы с функцией СРЗНАЧ в током случае не будет отличаться от описанного выше.

Ручной ввод функции

Но, не забывайте, что всегда при желании можно ввести функцию «СРЗНАЧ» вручную. Она будет иметь следующий шаблон: «=СРЗНАЧ(адрес_диапазона_ячеек(число); адрес_диапазона_ячеек(число)).

Ручной ввод функции в Microsoft Excel

Конечно, этот способ не такой удобный, как предыдущие, и требует держать в голове пользователя определенные формулы, но он более гибкий.

Среднее время расчет (Формулы/Formulas)

​ ленте в блоке​

​ получился​ процент за этот​ ​Строка: Е,​ дневная рабочая неделя,​Вот именно так.​Заранее спасибо!!​ в числовом формате​вернет значение времени​ 03:00 утра.​ число 0,4375 соответствует​ ​Когда все данные введены,​ ​ значения которых будут​ шаблон: «=СРЗНАЧ(адрес_диапазона_ячеек(число); адрес_диапазона_ячеек(число)).​ кнопку «OK».​ числа, так и​ отдельности, а не​ инструментов «Редактирование». Из​ ​chumich​ период? Любым удобным​Там время стоянки​

​ минус выходные и​

​ Вроде, мелочь, а​ ​_Boroda_​

​ – это 1/24/60/60.​

​ в числовом формате​

#8. ЕСЛИОШИБКА

Синтаксис: =ЕСЛИОШИБКА(значение;значение_если_ошибка)

значение — аргумент, который проверяется на наличие ошибки

значение_если_ошибка — значение, которое возвращается, если произошла ошибка.

Эта функция проверяет аргумент на равенство значениям ошибок #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0, #ЧИСЛО!, #ИМЯ? или #ПУСТО!. Если выражение в ячейке, которая проверяется, содержит ошибку, функция вернет значение, которое определено в этом случае. Если ошибки нет — результат расчетов или данные ячейки. Часто используется при делении на ноль.

Пример

Возьмем таблицу со значениями выручки и количеством проданных единиц. Нужно найти выручку за одну единицу продукции. Для решения этой задачи выручку делим на количество единиц.

image1.png

Excel ругается, потому что в одном выражении выполняется деление на ноль. Поэтому проверяем на ошибку в соседнем столбце.

image18.png

Свойства средней арифметической (математического ожидания)

Теперь рассмотрим свойства средней арифметической, которые часто используются при алгебраических манипуляциях. Правильней будет вновь вернутся к термину математического ожидания, т.к. именно его свойства приводят в учебниках.

Матожидание в русскоязычной литературе обычно обозначают как M(X), в иностранных учебниках можно увидеть E(X). Встречается обозначение греческой буквой μ (читается «мю»). Для удобства предлагаю вариант M(X).

Итак, свойство 1. Если имеются переменные X, Y, Z, то математическое ожидание их суммы равно сумме их математических ожиданий.

M(X+Y+Z) = M(X) + M(Y) + M(Z)

Допустим, среднее время, затрачиваемое на мойку автомобиля M(X) равно 20 минут, а на подкачку колес M(Y) – 5 минут. Тогда общее среднее арифметическое время на мойку и подкачку составит M(X+Y) = M(X) + M(Y) = 20 + 5 = 25 минут.

Свойство 2. Если переменную (т.е. каждое значение переменной) умножить на постоянную величину (a), то математическое ожидание такой величины равно произведению матожидания переменной и этой константы.

M(aX) = aM(X)

К примеру, среднее время мойки одной машины M(X) 20 минут. Тогда среднее время мойки двух машин составит M(aX) = aM(X) = 2*20 = 40 минут.

Свойство 3. Математическое ожидание постоянной величины (а) есть сама эта величина (а).

M(a) = a

Если установленная стоимость мойки легкового автомобиля равна 100 рублей, то средняя стоимость мойки нескольких автомобилей также равна 100 рублей.

Свойство 4. Математическое ожидание произведения независимых случайных величин равно произведению их математических ожиданий.

M(XY) = M(X)M(Y)

Автомойка за день в среднем обслуживает 50 автомобилей (X). Средний чек – 100 рублей (Y). Тогда средняя выручка автомойки в день M(XY) равна произведению среднего количества M(X) на средний тариф M(Y), т.е. 50*100 = 500 рублей.

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...