СЧЁТЕСЛИ (функция СЧЁТЕСЛИ)

Консультация эксперта. Как подсчитать количество ячеек, удовлетворяющих заданному условию?

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» – любой символ. «*» – любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (~).
  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.

Как вызвать функцию СЧЁТЕСЛИ СЧЁТЕСЛИ в MS Excel.

Нажимаем на кнопу Вставить функцию и в открывшемся диалоговом окне Вставка функции, в поле поиск, пишем СЧЁТЕСЛИ. Нажимаем найти. Обращаю внимание, что в поле поиска, писать СЧЁТЕЛСИ, необходимо именно с буквой Ё. По-другому поиск не найдет интересующую нас функцию. По результатам поиска, выбираем нужную нам функцию.

Функция СЧЁТЕСЛИ в MS Excel. Описание и примеры

Подсчет числовых значений с одним критерием

Данные будем брать из диапазона A15:A25 (см. файл примера ).

COUNT-6.png

Критерий

Формула

Результат

Примечание

>=10

= СЧЁТЕСЛИ($A$2:$A$12; “>=10”)

4

Подсчитывает количество ячеек, содержащих числа равных или более 10. Критерий указан в формуле

= СЧЁТЕСЛИ( $A$2:$A$12;C3)

8

Подсчитывает количество ячеек, содержащих числа равных или меньших 10. Критерий указан через ссылку

>= (ячейка С4)11(ячейка С5)

= СЧЁТЕСЛИ($A$2:$A$12; C4&C5)

3

Подсчитывает количество ячеек, содержащих числа равных или более 11. Критерий указан через ссылку и параметр

Примечание . О подсчете значений, удовлетворяющих нескольким критериям читайте в статье Подсчет значений со множественными критериями . О подсчете чисел с более чем 15 значащих цифр читайте статью Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL .

Описание функции СЧЁТЕСЛИ

СЧЁТЕСЛИ(диапазон; критерий)
Подсчитывает количество непустых ячеек в диапазоне, удовлетворяющих заданному условию.

  • Диапазон — диапазон ячеек по которым необходимо выполнить подсчет;
  • Критерий — условие, определяющее какие ячейки нужно подсчитать. Условие должно быть в виде числа, ссылки на ячейку, выражения и т.д.

Описание

Microsoft Excel функция СЧЁТЕСЛИ в Microsoft Excel подсчитывает количество ячеек в диапазоне, который соответствует заданным критериям.
СЧЁТЕСЛИ – это встроенная в Excel функция, которая относится к категории статистических функций.
Её можно использовать как функцию рабочего листа (WS) в Excel.
Как функцию рабочего листа, функцию СЧЁТЕСЛИ можно ввести как часть формулы в ячейку рабочего листа. Если вы хотите применить несколько критериев, попробуйте использовать функцию СЧЁТЕСЛИМН.

Распространенные неполадки

Проблема

Возможная причина

Для длинных строк возвращается неправильное значение.

Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов.

Для работы с такими строками используйте функцию СЦЕПИТЬ или оператор сцепления &. Пример: =СЧЁТЕСЛИ(A2:A5;”длинная строка”&”еще одна длинная строка”).

Функция должна вернуть значение, но ничего не возвращает.

Аргумент критерий должен быть заключен в кавычки.

Формула СЧЁТЕ ЕСЛИ получает #VALUE! при ссылке на другой таблицу.

Эта ошибка возникает при вычислении ячеек, когда в формуле содержится функция, которая ссылается на ячейки или диапазон в закрытой книге. Для работы этой функции необходимо, чтобы другая книга была открыта.

Синтаксис

=COUNTIF(range,criteria) – английская версия

=СЧЁТЕСЛИ(где нужно искать;что нужно найти) – русская версия

Пример использования функции СЧЁТЕСЛИ

Предположим у нас есть данные по продажам продуктов в магазине:

Таблица с данными по продажам
Подсчитаем количество категорий продуктов, относящихся отдельно к овощам и фруктам (критерий №1 в нашем примере).
В качестве диапазона выбираем ячейки A2:A13 (категория продукта) и задаем критерий подсчета F3 («Овощи»):

Пример №1 использования функции СЧЁТЕСЛИ

Пример №1 использования функции СЧЁТЕСЛИ

Теперь подсчитаем количество проданных продуктов свыше определенного количества килограмм (критерий №2 в нашем примере).
В качестве диапазона выбираем ячейки C2:C13 (объем продаж в кг) и задаем критерий подсчета F7 (“>500”):

Пример №2 использования функции СЧЁТЕСЛИ

Пример №2 использования функции СЧЁТЕСЛИ

Удачи вам и до скорых встреч на страницах блога Tutorexcel.ru!

Применение

  • Excel для Office 365, Excel 2019, Excel 2016, Excel 2013, Excel 2011 для Mac, Excel 2010, Excel 2007, Excel 2003, Excel XP, Excel 2000

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Использование СЧЕТЕСЛИ для подсчета дубликатов.

Другое возможное использование функции СЧЕТЕСЛИ в Excel – для поиска дубликатов в одном столбце, между двумя столбцами или в строке.

1. Ищем дубликаты в одном столбце

Эта простое выражение СЧЁТЕСЛИ($A$2:$A$24;A2)>1 найдет все одинаковые записи в A2: A24.

А другая формула СЧЁТЕСЛИ(B2:B24;ИСТИНА) сообщит вам, сколько существует дубликатов:

Для более наглядного представления найденных совпадений я использовал условное форматирование значения ИСТИНА.

2. Сколько совпадений между двумя столбцами?

Сравним список2 со списком1. В столбце Е берем последовательно каждое значение из списка2 и считаем, сколько раз оно встречается в списке1. Если совпадений ноль, значит это уникальное значение. На рисунке такие выделены цветом при помощи условного форматирования.

Выражение  =СЧЁТЕСЛИ($A$2:$A$24;C2) копируем вниз по столбцу Е.

Аналогичный расчет можно сделать и наоборот – брать значения из первого списка и искать дубликаты во втором.

Для того, чтобы просто определить количество дубликатов, можно использовать комбинацию функций СУММПРОИЗВ и СЧЕТЕСЛИ.

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:A24;C2:C24)>0)*(C2:C24<>””))

Подсчитаем количество уникальных значений в списке2:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:A24;C2:C24)=0)*(C2:C24<>””))

Получаем 7 уникальных записей и 16 дубликатов, что и видно на рисунке.

Полезное. Если вы хотите выделить дублирующиеся позиции или целые строки, содержащие повторяющиеся записи, вы можете создать правила условного форматирования на основе формул СЧЕТЕСЛИ, как показано в этом руководстве – правила условного форматирования Excel.

3. Сколько дубликатов и уникальных значений в строке?

Если нужно сосчитать дубликаты или уникальные значения в определенной строке, а не в столбце, используйте одну из следующих формул. Они могут быть полезны, например, для анализа истории розыгрыша лотереи.

Считаем количество дубликатов:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:K2;A2:K2)>1)*(A2:K2<>””))

Видим, что 13 выпадало 2 раза.

Подсчитать уникальные значения:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:K2;A2:K2)=1)*(A2:K2<>””))

См. также

Для подсчета непустых ячеек используйте функцию СЧЁТЗ

Для подсчета ячеек на основании нескольких критериев используйте функцию СЧЁТЕСЛИМН

Просмотрите видео об использовании функции СЧЁТЕСЛИМН

Функция СУММЕСЛИ суммирует только те значения, которые соответствуют одному условию

Функция СУММЕСЛИМН суммирует только те значения, которые соответствуют нескольким условиям

Функция ЕСЛИМН (Microsoft 365, Excel 2016 и более поздних)

Для удаления начальных и конечных пробелов в ячейках используйте функцию СЖПРОБЕЛЫ

Для удаления непечатаемых символов в ячейках используйте функцию ПЕЧСИМВ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Статистические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Формула ЕСЛИ в Excel – примеры нескольких условий

Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

esli_eslimn_04.png

Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2<1, то условия B2<0,9 и B2<0,95 Excel бы просто «не заметил», т.к. они входят в интервал B2<1 который проверился бы первым (если значение менее 0,9, само собой, оно также меньше и 1). И тогда у нас получилось бы только два возможных варианта: менее 1 и альтернативное, т.е. 1 и более.

При написании формулы легко запутаться, поэтому рекомендуется смотреть на всплывающую подсказку.

esli_eslimn_05.png

В конце нужно обязательно закрыть все скобки, иначе эксель выдаст ошибку

esli_eslimn_06.png

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...