Полезные функции Excel

Отображение функций в Excel с картинами и готовыми образцами их внедрения на практике. Вычислительные операции с формулами.

#1. СУММ

Синтаксис: =СУММ(число1;[число2];…)

число1 — обязательный аргумент.

Функция дает возможность найти сумму отдельных числовых значений, диапазонов, ссылок на ячейки с числовыми значениями или сумму всех этих 3-х видов. Часто используется в подбивании итоговых значений строк или столбцов при формировании отчетов.

Примеры использования

Допустим, у вас есть массив числовых значений и вам нужно посчитать сумму некоторых из них. Используя функцию СУММ, в области аргументов функции мы подставляем нужные ссылки на ячейки и получаем ответ — 312.

В кое-каких случаях в массивах не находятся значения, которые нужно так же просуммировать, и вместо ссылок можем добавить свои числа. Ответ в этом случае — 419.

image14.png

Так как функция работает не только с числовыми значениями, а и с целыми диапазонами, можно найти сумму всего диапазона.

image3.png

Можно не ограничивать себя в количестве значений, которые нужно просуммировать, а посчитать все значения в столбцах или строках. К примеру, просуммируем все значения в первых двух столбцах.

image8.png

Если в одной или нескольких ячейках диапазона окажется не числовое выражение, а текстовое, Excel будет приравнивать эти значения к нулю.

image17.png

#3. МИН

Синтаксис: =МИН(число1;[число2];…)

число1 — обязательный аргумент.

Функция позволяет найти минимальное числовое значение в указанном списке аргументов. Часто используется при построении финансовой отчетности, когда нужно определить дату начала периода отчета, минимальный чек покупки и другие параметры.

Пример

Допустим, у нас есть диапазон чисел и текстовых выражений, и нужно найти минимальное значение.

image5.png

Например, минимальное значение среди двух выбранных диапазонов A1:D2, A4:D4 и числа 54 будет 21. Пустые поля и текстовые выражения функцией исключаются и в расчетах не используются.

Близкие по назначению функции

=МИНА(значение1;[значение2];…) — находит минимальное значение в списке аргументов, при этом текстовые и ложные логические выражения равняются к нулю, а логическое выражение “ИСТИНА” в ячейке равняется 1.

=МАКС(число1;[число2];…) — находит максимальное значение в списке аргументов, при этом текстовые и пустые выражения игнорируются.

=МАКСА(значение1;[значение2];…) — находит максимальное значение в списке аргументов, при этом текстовые и ложные логические выражения приравниваются к нулю, а логическое выражение “ИСТИНА” в ячейке равняется 1.

#5. ОКРУГЛ

Синтаксис: =ОКРУГЛ(число; число_разрядов)

число — аргумент.

число_разрядов — до какого разряда округляется число.

Функция ОКРУГЛ применяется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение согласно математическому правилу округления.

К примеру, для округления числа 2,57525 до 2-х символов после запятой можно ввести формулу =ОКРУГЛ(2,57525;2), которая вернет значение 2,58. Эта функция часто используется при построении балансовых и других видов отчетности.

#7. ВПР

Синтаксис: =ВПР(искомое_значение; таблица; номер_столбца; [интервальный_просмотр])

искомое_значение — значение, которое необходимо найти в столбце с данными. Аргументы бывают числовыми и текстовыми. Искомое значение должно находиться в крайнем левом столбце диапазона ячеек указанной таблицы.

таблица — ссылка на диапазон ячеек. В левом столбце выполняется поиск искомого значения, а из столбцов правее выводится соответствующее значение. Левый столбец еще называют ключевым. Если в таблице не окажется искомого значения, вернется ошибка #Н/Д.

номер_столбца — номер столбца таблицы, согласно которому нужно вывести результат.

[интервальный_просмотр] — необязательный аргумент. Принимает два значения: ИСТИНА и ЛОЖЬ. ИСТИНА устанавливается по умолчанию, и функция предполагает, что левый столбец таблицы отсортирован по возрастанию в алфавитном порядке. Если в этом аргументе — ИСТИНА, функция ищет ближайшее к искомому или совпадающее с ним значение, ЛОЖЬ — ищет стопроцентное совпадение с искомым значением.

Это функция, которая упростит работу с большими массивами данных и несколькими таблицами. Будет полезной, если нужно подтянуть соответствующий критерию столбец из другой таблицы (например, группа, категория).

Пример

Вернемся к нашей таблице из пункта 6 (ЕСЛИ). Предположим, что каждому предмету покупки присвоили группу, к которой он относится (овощи, фрукты, кондитерские изделия и др.), и у нас есть справочник соответствий, но в другой таблице. В массивах данных, состоящих из тысяч строк, делать это вручную очень долго, а ВПР справится за долю секунды.

image11.png

В ячейке G2 пишем формулу: =ВПР(A2;$L$2:$M$78;2;ЛОЖЬ). Обязательно ставим знаки фиксации диапазона $ — в случае их отсутствия при протягивании формулы вниз диапазон ячеек таблицы также будет смещаться вниз вместе с искомым значением.

Как прочитать формулу простым языком: найти значение из ячейки A2 в левом столбце таблицы L2:M78 и вывести соответствующее найденному искомому_значению выражение из столбца 2 этой таблицы, при этом искомое значение должно совпадать с данными в левом столбце таблицы (аргумент ЛОЖЬ).

image6.png

Протягиваем формулу вниз — и выводится результат.

image16.png

Функции даты и времени

Функции даты и времениЧтобы вычислить показатели, связанные с каким-либо временным периодом, можно воспользоваться следующими примерами:

  • Дата. Выделенное число приобретает формат даты.
  • Разндат. Демонстрирует разницу в годах, месяцах и днях между двумя выбранными датами.
  • Датазнач. Текстовый формат, в котором указана дата, приобретает числовой вид. дата в эксель
  • Дней360. За основу берется год из 360 дней, который и выделяет количество дней между двумя датами.
  • Датамес. Показывает состояние даты через указанное количество месяцев или дней.

Датазнач пример фунции

Перед использованием нужно зайти в раздел «Формат ячеек» и выбрать в них соответствующую группу форматов.

Важно! Без выполнения этих шагов возможны ошибки при выполнении операции.

#9. СЖПРОБЕЛЫ

Синтаксис: =СЖПРОБЕЛЫ(текст)

текст — текстовое значение, из которого необходимо удалить лишние пробелы.

Эту функцию используют для обработки текстов из разных источников. Когда в этих текстах есть лишние пробелы, они удаляются.

Пример

Формула =СЖПРОБЕЛЫ(”      Выручка     с начала                года   “) вернет “Выручка с начала года”, убрав из выражения лишние пробелы.

С помощью функции можно удалить из текста лишние знаки пробела (код символа — 32). В некоторых случаях в тексте может присутствовать знак неразрывного пробела (код — 160). Чтобы удалить эти лишние знаки, нужно использовать следующую формулу: =СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;СИМВОЛ(160);СИМВОЛ(32))). В таком случае функция сначала заменяет все знаки неразрывного пробела на пробел, а после этого удаляет лишние пробелы.

Формула 11: ПОИСКПОЗ

Эта функция дает возможность найти требуемый элемент среди диапазона ячеек и выдать его положение.

Шаблон этой формулы такой:

=ПОИСКПОЗ(искомое_значение;просматриваемый_массив;тип_сопоставления)

Первые два аргумента обязательные, последний – нет.

Существует три способа сопоставления:

  1. Меньше или равно – 1.
  2. Точное – 0.
  3. Самое маленькое значение, равно искомому или большего него -1.

В данном примере мы пытаемся определить, какой по какому из ключевых слов осуществляется до 900 переходов включительно.ТОП 15 формул в Excel

#10. СЦЕПИТЬ

Синтаксис: =СЦЕПИТЬ(текст1;[текст2];[текст3];…)

текст1 — обязательный аргумент.

Для объединения значений из разных ячеек в одну используется функция СЦЕПИТЬ. Также можно применять аналог — & (амперсанд). Функция часто используется для объединения данных с нескольких столбцов.

Пример

Допустим, у нас есть таблица сотрудников с разделенными ФИО, должностью и возрастом, а в отчете нужно отобразить все эти значения в одной ячейке. Для выполнения этой задачи используем функцию так:

image10.png

Хотите получать дайджест статей?

Одно письмо с лучшими материалами за неделю. Подписывайтесь, чтобы ничего не упустить.

Спасибо за подписку!

Последние материалы

img-mascot-619faf0bec82a355501337.jpg

Как появилась идея говорящих драже M&M’s и в чем успех английского капитана Моргана.

img-liski-619f751aeadcc188867888.jpg

Рассказываем, как диверсифицировать риски в бизнесе.

img-scale-619cf92ed4666983355637.png

Почему вам мало платят и не повышают в должности.

Формула 12: ДЛСТР

Эта функция дает возможность определить, какая длина у заданной строки.

Ее синтаксис аналогичен предыдущей:

=ДЛСТР(текст)

Так, она может использоваться, чтобы определить длину описания статьи при SEO-продвижении сайта.ТОП 15 формул в Excel

Также ее хорошо совмещать с функцией ЕСЛИ.

17) ИНДЕКС

Функция ИНДЕКС позволяет возвращать искомое значение.

Синтаксис

Формула функции ИНДЕКС имеет следующий вид:

=ИНДЕКС(массив; номер_строки; [номер_столбца])

«Номер столбца» – необязательный аргумент.

Пример

В этом примере введена формула: =ИНДЕКС(A2:B3;2;2), данным которой соответствует значение («сливы»)

Функцию ИНДЕКС можно использовать вместе с функцией ПОИСКПОЗ с целью замены функции ВПР.

Формула 14: ПРОПНАЧ

Эта функция меняет местами прописные и строчные символы.

Синтаксис очень простой:

=ПРОПНАЧ(текст)

Зачем интернет-маркетологу функции Excel?

Мы рассмотрели самые интересные и популярные функции Excel. Могут ли они быть полезны интернет-маркетологу? Безусловно. Они помогут при анализе данных страниц сайта, подсчете количества символов в тайтле и description, преобразовании текста, поиске различных элементов в таблице. Несмотря на то, что некоторые из представленных функций очень просты и понятны, это не умаляет их ценности ни для обычного пользователя, ни для интернет-маркетолога.

Вы хотите стать специалистом с хорошей зарплатой и возможностью карьерного роста? Приходите на онлайн-курсы TeachLine от «Текстерры» за новой профессией и новыми перспективами.

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...