Лекция Функции ВПР, СУММЕСЛИ, СЧЁТЕСЛИ . ОБРАБОТКА

Суммирование по условию с помощью функции Excel СУММЕСЛИ. Объяснение формулы и примеры использования. Альтернатива ВПР.

Содержание

Синтаксис

СУММЕСЛИ(диапазон; условие; [диапазон_суммирования])

Аргументы функции СУММЕСЛИ описаны ниже.

  • Диапазон   — обязательный аргумент. Диапазон ячеек, оцениваемых на соответствие условиям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые и текстовые значения игнорируются. Выбранный диапазон может содержать даты в стандартном формате Excel (см. примеры ниже).

  • Условие   .Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо суммировать. Можно включит под вопросицу (?), которая соответствует любому одиночному символу, звездочка (*) — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак “тильда” (~).

    Например, условия могут быть выражены как 32, “>32”, B5, “3?”, “яблок*”, “*~?”, или СЕГОДНЯ().

    Важно: Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки (). Если условием является число, использовать кавычки не требуется.

  • Диапазон_суммирования   .Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

    Sum_range должны быть того же размера и фигуры, что идиапазон . В этом случае производительность может понести убытки, и формула суммирует диапазон ячеек, который начинается с первой ячейки в sum_range но имеет те же измерения, что и диапазон. Например:

    диапазон

    Диапазон_суммирования.

    Фактические суммные ячейки

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1:K5

    B1:B5

Функция СУММЕСЛИ Excel.

Ниже приведены варианты функции СУММЕСЛИ Excel. Описания, пошаговый алгоритм использования в зависимости от варианта функции, с примерами использования и иллюстрациями.

СУММЕСЛИ следует использовать в тех случаях, когда Вам необходимо суммировать значения в диапазоне, которые соответствует указанному Вами критерию.

Возможные варианты данной функции:

  • сумма, если больше;
  • сумма, если меньше;
  • сумма, если равно;
  • сумма, если не равно;
  • сумма если больше или равно;
  • сумма если меньше или равно.

Отдельная статья описывает функцию СУММЕСЛИ Excel. Точное совпадение. Частичное совпадение. С  текстовыми критерий. Содержит описание, примеры и иллюстрации. Статья находиться по этой ссылке: Функция СУММЕСЛИ в MS Excel. Точное совпадение. Частичное совпадение. Инструкция и примеры.

Самый простой и понятный способ вызвать данную функцию, это нажать в правом верхнем углу, рядом с кнопкой ∑, стрелку вниз (Рис. 1).

Функция СУММЕСЛИ Excel, варианты и примеры

Рис 1

.

Появиться список функций. Как правило, это наиболее часто используемые функции. В этом списке уже может быть нужная Вам функция СУММЕСЛИ. В нашем случае ее там нет. Тогда выбираем пункт Другие функции. Он находиться внизу списка (Рис. 2).

Функция СУММЕСЛИ Excel, варианты и примеры

Рис 2

Появляется диалоговое окно – Вставка функции. Самое верхнее, это поле для поиска нужной функции. Вводим название функции, выбираем ее в результатах поиска и нажимаем ОК (Рис. 3).

Функция СУММЕСЛИ Excel, варианты и примеры

Рис. 3

Появляется диалоговое окно — Аргументы функции (Рис. 4).

Функция СУММЕСЛИ Excel, варианты и примеры

Рис. 4

В нем есть три ключевых поля для заполнения:

  1. Диапазон — здесь указываться диапазон ячеек, в которых будет происходить поиск по указанному критерию;
  2. Критерий — здесь будет указан сам критерий поиска;
  3. Диапазон _ суммирования, здесь указывается диапазон ячеек, данные в которых будут суммироваться, исходя из критерия поиска. Применяется не во всех случаях.

Что бы выбрать нужный диапазон нажимаете на стрелочку в конце строки диапазона и выбираете нужные Вам ячейки с помощью мыши. Можно сразу выбрать нужный диапазон, не нажимая на стрелочку, но сначала нужно поставив курсор на нужную строку в диалоговом окне. Можно прописать диапазон вручную. Результат от этого не зависит. После того как все готово, нажимает ОК  (Рис. 5).

Функция СУММЕСЛИ Excel, варианты и примеры

Рис. 5

Простое сложение в Excel

Складывать значения ячеек можно с помощью простой функции «СУММ», которая суммирует выбранные значения без определенного условия. Она используется, когда есть ячейки, массив или несколько массивов для сложения. В этом случае достаточно выделить нужные элементы электронной таблицы и применить функцию. Она играет роль обычного калькулятора со знаком «+».

Функция СУММ в Excel

Как отобразить все скрытые строки или столбцы в Excel?

Василий19:36:00 Add Comment

При работе в Excel вы скрыли много строк и/или столбцов и теперь их надо всех быстро отобразить? Прочитайте эту статью, и вы узнаете, как эт…

Далее…

Что возвращает функция

Возвращает сумму чисел, указанных в качестве аргументов и отвечающих заданным в формуле критериям.

Общие сведения о функции СУММЕСЛИ

Как видно из названия, эта функция осуществляет суммирование значений, соответствующих определенному условию. Она позволяет заменить сложную формулу одной функцией.

Далее рассмотрим варианты использования данной функции на конкретных примерах, что бы понять, как они работают.

Напоминаю, что перед тем, как вызывать функцию, нужно выбрать ячейку, в которой должно появиться искомое значение, результат применения функции. 

Примеры

Пример 1

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Стоимость имущества

Комиссионные

Данные

1 000 000 ₽

70 000 ₽

2 500 000 ₽

2 000 000 ₽

140 000 ₽

3 000 000 ₽

210 000 ₽

4 000 000 ₽

280 000 ₽

Формула

Описание

Результат

=СУММЕСЛИ(A2:A5;”>160000″;B2:B5)

Сумма комиссионных за имущество стоимостью больше 1 600 000 ₽.

630 000 ₽

=СУММЕСЛИ(A2:A5; “>160000”)

Сумма по имуществу стоимостью больше 1 600 000 ₽.

9 000 000 ₽

=СУММЕСЛИ(A2:A5;300000;B2:B5)

Сумма комиссионных за имущество стоимостью 3 000 000 ₽.

210 000 ₽

=СУММЕСЛИ(A2:A5;”>” &C2;B2:B5)

Сумма комиссионных за имущество, стоимость которого превышает значение в ячейке C2.

490 000 ₽

Пример 2

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. Кроме того, вы можете настроить ширину столбцов в соответствии с содержащимися в них данными.

Категория

Продукты

Объем продаж

Овощи

Помидоры

23 000 ₽

Овощи

Сельдерей

55 000 ₽

Фрукты

Апельсины

8 000 ₽

Масло

4 000 ₽

Овощи

Морковь

42 000 ₽

Фрукты

Яблоки

12 000 ₽

Формула

Описание

Результат

=СУММЕСЛИ(A2:A7;”Фрукты”;C2:C7)

Объем продаж всех продуктов категории “Фрукты”.

20 000 ₽

=СУММЕСЛИ(A2:A7;”Овощи”;C2:C7)

Объем продаж всех продуктов категории “Овощи”.

120 000 ₽

=СУММЕСЛИ(B2:B7;”*ы”;C2:C7)

Объем продаж всех продуктов, названия которых заканчиваются на “ы” (“Помидоры” и “Апельсины”).

43 000 ₽

=СУММЕСЛИ(A2:A7;””;C2:C7)

Объем продаж всех продуктов, категория для которых не указана.

4 000 ₽

К началу страницы

Примеры использования функции СУММЕСЛИ в Excel

Сумма если больше чем, меньше, или равно

Начнем с самого простого. Предположим, у нас есть данные о продажах шоколада. Рассчитаем различные варианты продаж.

В I3 записано:

=СУММЕСЛИ(D2:D21;I2)

D2:D21 – это координаты, в которых мы ищем значение.

I2 – ссылка на критерий отбора. Иначе говоря, мы ищем ячейки со значением 144 и складываем их.

Поскольку третий параметр функции не указан, то мы сразу складываем отобранные числа. Область поиска будет одновременно являться и диапазоном суммирования.

Кроме того, в качестве задания для отбора нужных значений можно указать текстовое выражение, состоящее из знаков >, <, <>, <= или >= и числа.

Можно указать его прямо в формуле, как это сделано в I13

=СУММЕСЛИ(D2:D21;“<144”)

То есть подытоживаем все заказы, в которых количество меньше 144.

Но, согласитесь, это не слишком удобно, поскольку нужно корректировать саму формулу, да и условие еще нужно не забыть заключить в кавычки.

В дальнейшем мы будем стараться использовать только ссылку на критерий, поскольку это значительно упрощает возможные корректировки.

Критерии для текста.

Гораздо чаще встречаются ситуации, когда поиск нужно проводить в одном месте, а в другом – суммировать данные, соответствующие найденному.

Чаще всего это необходимо, если необходимо использовать отбор по определённым словам. Ведь текстовые значения складывать нельзя, а вот соответствующие им числа – можно.

Как простой прием использования формулы СУММЕСЛИ в Эксель таблицах, рассчитаем итог по выполненным заказам.

В I3 запишем выражение:

=СУММЕСЛИ(F2:F21;I2;E2:Е21)

F2:F21 – это область, в которой мы отбираем подходящие значения.

I2 – здесь записано, что именно отбираем.

E2:E21 – складываем числа, соответствующие найденным совпадениям.

Конечно, можно указать параметр отбора прямо в выражении:

=СУММЕСЛИ(F2:F21;”Да”;E2:Е21)

Но мы уже договорились, что так делать не совсем рационально.

Важное замечание. Не забываем, что все текстовые значения необходимо заключать в кавычки.

Подстановочные знаки для частичного совпадения.

При работе с текстовыми данными часто приходится производить поиск по какой-то части слова или фразы.

Вернемся к нашему случаю. Определим, сколько всего было заказов на черный шоколад. В результате, у нас есть 2 подходящих наименования товара. Как учесть их оба? Для этого есть понятие неточного соответствия.

Мы можем производить поиск и подсчет значений, указывая не всё содержимое ячейки, а только её часть. Таким образом мы можем расширить границы поиска, применив знаки подстановки “?”, “*”.

Символ “?” позволяет заменить собой один любой символ.

Символ ”*” позволяет заменить собой не один, а любое количество символов (в том числе ноль).

Эти знаки можно применить в нашем случае двумя способами. Либо прямо вписать их в таблицу –

=СУММЕСЛИ(C2:C21;I2;E2:Е21) , где в E2 записано *[слово]*

либо

=СУММЕСЛИ(C2:C21;”*”&I2&”*”;E2:E21)

где * вставлены прямо в выражение и «склеены» с нужным текстом.

Давайте потренируемся:

  • “*черный*” – мы ищем фразу, в которой встречается это выражение, а до него и после него – любые буквы, знаки и числа. В нашем случае этому соответствуют “Черный шоколад” и “Супер Черный шоколад”.
  • “Д?” – необходимо слово из 2 букв, первая из которых “Д”, а вторая – любая. В нашем случае подойдет “Да”.
  • “???” – найдем слово из любых 3 букв

=СУММЕСЛИ(F2:F21;”???”;E2:E21)

Этому требованию соответствует “Нет”.

  • “???????*” – текст из любых 7 и более букв.

=СУММЕСЛИ(B2:B21;“???????*”;E8:E28)

Подойдет “Зеленый”, “Оранжевый”, “Серебряный”, “Голубой”, “Коричневый”, “Золотой”, “Розовый”.

  • “З*” – мы выбираем фразу, первая буква которой “З”, а далее – любые буквы, знаки и числа. Это “Золотой” и “Зеленый”.
  • “Черный*” – подходит фраза, которая начинаются именно с этого слова, а далее – любые буквы, знаки и числа. Подходит “Черный шоколад”.

Примечание. Если вам необходимо в качестве задания для поиска применять текст, который содержит в себе * и ?, то используйте знак тильда (~), поставив его перед этими символами. Тогда * и ? будут считаться обычными символами, а не шаблоном:

=СУММЕСЛИ(B2:B21;“*~?*”;E8:E28)

Важное замечание. Если в вашем тексте для поиска встречается несколько знаков * и ?, то тильду (~) нужно поставить перед каждым из них. К примеру, если мы будем искать текст, состоящий из трех звездочек, то можено записать так:

=СУММЕСЛИ(B2:B21;“~*~*~*”;E8:E28)

А если текст просто содержит в себе 3 звездочки, то можно наше выражение переписать так:

=СУММЕСЛИ(B2:B21;“*~*~*~**”;E8:E28)

Точная дата либо диапазон дат.

Если нам нужно найти сумму чисел, соответствующих определённой дате, то проще всего в качестве критерия указать саму эту дату.

Примечание. При этом не забывайте, что формат указанной вами даты должен соответствовать региональным настройкам вашей таблицы!

Обратите внимание, что мы также можем здесь вписать ее прямо в формулу, а можем использовать ссылку.

Рассчитываем итог продаж за сегодняшний день – 04.02.2020г.

=СУММЕСЛИ(A2:A21;I1;E2:E21)

или же

=СУММЕСЛИ(A2:A21;СЕГОДНЯ();E2:E21)

Рассчитаем за вчерашний день.

=СУММЕСЛИ(A2:A21;СЕГОДНЯ()-1;E2:E21)

СЕГОДНЯ()-1 как раз и будет “вчера”.

Складываем за даты, которые предшествовали 1 февраля.

=СУММЕСЛИ(A2:A21;”<“&”01.02.2020”;E2:E21)

После 1 февраля включительно:

=СУММЕСЛИ(A2:A21;”>=”&”01.02.2020″;E2:E21)

А если нас интересует временной интервал “от-до”?

Мы можем рассчитать итоги за определённый период времени. Для этого применим маленькую хитрость: разность функций СУММЕСЛИ. Предположим, нам нужна выручка с 1 по 4 февраля включительно. Из продаж после 1 февраля вычитаем все, что реализовано до 4 февраля.

=СУММЕСЛИ(A2:A21;”>=”&”01.02.2020″;E2:E21) – СУММЕСЛИ(A2:A21;”<=”&”04.02.2020″;E2:E21)

Сумма значений, соответствующих пустым либо непустым ячейкам

Случается, что в качестве условия суммирования нужно использовать все непустые клетки, в которых есть хотя бы одна буква, цифра или символ.

Рассмотрим ещё один вариант использования формулы СУММЕСЛИ в таблице Excel, где нам необходимо подсчитать заказы, в которых нет отметки о выполнении, а также сколько было вообще обработанных заказов.

Если критерий указать просто “*”, то мы учитываем для подсчета непустые ячейки, в которых имеется хотя бы одна буква или символ (кроме пустых).

=СУММЕСЛИ(F2:F21;”*”;E2:E21)

Точно такой же результат даёт использование вместо звездочки пары знаков «больше» и «меньше» – <>.

=СУММЕСЛИ(F2:F21;”<>”;E2:E21)

Теперь рассмотрим, как можно находить сумму, соответствующую пустым ячейкам.

Для того, чтобы найти пустые, в которых нет ни букв, ни цифр, в качестве критерия поставьте парные одинарные кавычки ‘’, если значение критерия указано в ячейке, а формула ссылается на неё.

Если же указать на отбор только пустых ячеек в самой формуле, то впишите двойные кавычки.

=СУММЕСЛИ(F2:F21;“”;E2:E21)

Сумма по нескольким условиям.

Функция СУММЕСЛИ может работать только с одним условием, как мы это делали ранее. Но очень часто случается, что нужно найти совокупность данных, удовлетворяющих сразу нескольким требованиям. Сделать это можно как при помощи некоторых хитростей, так и с использованием других функций. Рассмотрим все по порядку.

Вновь вернемся к нашему случаю с заказами. Рассмотрим два условия и найдем, сколько всего сделано заказов черного и молочного шоколада.

1. СУММЕСЛИ + СУММЕСЛИ

Все просто:

=СУММЕСЛИ($C$2:$C$21;”*”&H3&”*”;$E$2:$E$21)+СУММЕСЛИ($C$2:$C$21;”*”&H4&”*”;$E$2:$E$21)

Находим сумму заказов по каждому виду товара, а затем просто их складываем. Думаю, с этим вы уже научились работать :).

Это самое простое решение, но не самое универсальное и далеко не единственное.

2. СУММ и СУММЕСЛИ с аргументами массива.

Вышеупомянутое решение очень простое и может выполнить работу быстро, когда критериев немного. Но если вы захотите работать с несколькими, то она станет просто огромной. В этом случае лучшим подходом является использование в качестве аргумента массива критериев. Давайте рассмотрим этот подход.

Вы можете начать с перечисления всех ваших условий, разделенных запятыми, а затем заключить итоговый список, разделенный точкой с запятой, в {фигурные скобки}, который технически называется массивом.

Если вы хотите найти покупки этих двух товаров, то ваши критерии в виде массива будут выглядеть так:

СУММЕСЛИ($C$2:$C$21;{“*черный*”;”*молочный*”};$E$2:$E$21)

Поскольку здесь использован массив критериев, то результатом вычислений также будет массив, состоящий из двух значений.

А теперь воспользуемся функцией СУММ, которая умеет работать с массивами данных, складывая их содержимое.

=СУММ(СУММЕСЛИ($C$2:$C$21;{“*черный*”;”*молочный*”};$E$2:$E$21))

Важно, что результаты вычислений в первом и втором случае совпадают.

3. СУММПРОИЗВ и СУММЕСЛИ.

А если вы предпочитаете перечислять критерии в какой-то специально отведенной для этого части таблицы? Можете использовать СУММЕСЛИ в сочетании с функцией СУММПРОИЗВ, которая умножает компоненты в заданных массивах и возвращает сумму этих произведений.

Вот как это будет выглядеть:

=СУММПРОИЗВ(СУММЕСЛИ(C2:C21;H3:H4;E2:E21))

в H3 и H4 мы запишем критерии отбора.

Но, конечно, ничто не мешает вам перечислить значения в виде массива критериев:

=СУММПРОИЗВ(СУММЕСЛИ(C2:C21;{“*черный*”;”*молочный*”};E2:E21))

Результат, возвращаемый в обоих случаях, будет идентичен тому, что вы наблюдаете на скриншоте.

Важное замечание! Обратите внимание, что все перечисленные выше три способа производят расчет по логическому ИЛИ. То есть, нам нужны продажи шоколада, который будет или черным, или молочным.

Почему СУММЕСЛИ у меня не работает?

Этому может быть несколько причин. Иногда ваше выражение не возвращает того, что вы ожидаете, только потому, что тип данных в ячейке или в каком-либо аргументе не подходит для нее. Итак, вот что нужно проверить.

1. «Диапазон данных» и «диапазон суммирования» должны быть указаны ссылками, а не в виде массива.

Первый и третий атрибуты функции всегда должны быть ссылкой на область таблицы, например A1: A10. Если вы попытаетесь передать что-нибудь еще, например, массив {1,2,3}, Excel выдаст сообщение об ошибке.

Правильно: =СУММЕСЛИ(A1:A3, “цвет”, C1:C3)

Неверно : =СУММЕСЛИ({1,2,3}, “цвет”, C1:C3)

2. Ошибка при суммировании значений из других листов или рабочих книг

Как и любая другая функция Excel, СУММЕСЛИ может ссылаться на другие листы и рабочие книги, если они в данный момент открыты.

Найдем сумму значений в F2: F9 на листе 1 книги 1, если соответствующие данные записаны в столбце A, и если среди них содержатся «яблоки»:

=СУММЕСЛИ([Книга1.xlsx]Лист1!$A$2:$A$9,”яблоки”,[Книга1.xlsx]Лист1!$F$2:$F$9)

Однако это перестанет работать, как только Книга1 будет закрыта. Это происходит потому, что области, на которые ссылаются формулы в закрытых книгах, преобразуются в массивы и хранятся в таком виде в текущей книге. А поскольку в аргументах 1 и 3 массивы не допускаются, то формула выдает ошибку #ЗНАЧ!.

3. Чтобы избежать проблем, убедитесь, что диапазоны данных и поиска имеют одинаковый размер.

Как отмечалось в начале этого руководства, в современных версиях Microsoft Excel они не обязательно должны иметь одинаковый размер. Но вот в Excel 2000 и более ранних версиях это может вызвать проблемы. Однако, даже в самых последних версиях Excel 2010 и Excel 2016 сложные выражения, в которых диапазон сложения имеет меньше строк и/или столбцов, чем диапазон поиска, являются капризными. Вот почему рекомендуется всегда иметь их одинакового размера и формы.

Примеры расчета суммы:

Пример использования функции СУММЕСЛИ для сопоставления данных

Функцию СУММЕСЛИ можно использовать для связки данных. Действительно, если просуммировать одно значение, то получится само это значение. Короче, СУММЕСЛИ легко приспособить для связки данных как альтернативу функции ВПР. Зачем использовать СУММЕСЛИ, если существует ВПР? Поясняю. Во-первых, СУММЕСЛИ в отличие от ВПР нечувствительна к формату данных и не выдает ошибку там, где ее меньше всего ждешь; во-вторых, СУММЕСЛИ вместо ошибок из-за отсутствия значений по заданному критерию выдает 0 (нуль), что позволяет без лишних телодвижений подсчитывать итоги диапазона с формулой СУММЕСЛИ. Однако есть и один минус. Если в искомой таблице какой-либо критерий повторится, то соответствующие значения просуммируются, что не всегда есть «подтягивание». Лучше быть настороже. С другой стороны зачастую это и нужно – подтянуть значения в заданное место, а задублированные позиции при этом сложить. Нужно просто знать свойства функции СУММЕСЛИ и использовать согласно инструкции по эксплуатации.

Теперь рассмотрим пример, как функция СУММЕСЛИ оказывается более подходящей для подтягивания данных, чем ВПР. Пусть данные из примера ваше – это продажи некоторых товаров за январь. Мы хотим узнать, как они изменились в феврале. Сравнение удобно произвести в этой же табличке, предварительно добавив еще один столбец справа и заполнив его данными за февраль. Где-то в другом экселевском файле есть статистика за февраль по всему ассортименту, но нам хочется проанализировать именно эти позиции, для чего требуется из большого файла со статистикой продаж всех товаров подтянуть нужные значения в нашу табличку. Для начала давайте попробуем воспользоваться формулой ВПР. В качестве критерия будем использовать код товара. Результат на рисунке.

Ошибки при использовании функции ВПР

Отчетливо видно, что одна позиция не подтянулась, и вместо числового значения выдается ошибка #Н/Д. Скорее всего, в феврале этот товар просто не продавался и поэтому он отсутствует в базе данных за февраль. Как следствие ошибка #Н/Д показывается и в сумме. Если позиций не много, то проблема не большая, достаточно вручную удалить ошибку и сумма будет корректно пересчитана. Однако количество строчек может измеряться сотнями, и рассчитывать на ручную корректировку не совсем верное решение. Теперь воспользуемся формулой СУММЕСЛИ вместо ВПР.

Использование СУММЕСЛИ вместо ВПР

Результат тот же, только вместо ошибки #Н/Д СУММЕСЛИ выдает нуль, что позволяет нормально рассчитать сумму (или другой показатель, например, среднюю) в итоговой строке. Вот это и есть основная идея, почему СУММЕСЛИ иногда следует использовать вместо ВПР. При большом количестве позиций эффект будет еще более ощутимым.

На сегодня все. Всех благ и до новых встреч на statanaliz.info.

Поделиться в социальных сетях:

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Задача4 (Месяц)

Немного модифицируем условие предыдущей задачи: найдем суммарные продаж за месяц(см. файл примера Лист Месяц ).

Формулы строятся аналогично задаче 3, но пользователь вводит не 2 даты, а название месяца (предполагается, что в таблице данные в рамках 1 года).

sumpng-6.png

Месяц вводится с помощью Выпадающего списка , перечень месяцев формируется с использованием Динамического диапазона (для исключения лишних месяцев).

См. также

Функция СУММЕСЛИМН суммирует все аргументы, которые соответствуют нескольким условиям

Функция СУММКВ суммирует несколько значений, предварительно возведя каждое из них в квадрат

Функция СЧЁТЕСЛИ подсчитывает только те значения, которые соответствуют одному условию

Функция СЧЁТЕСЛИМН подсчитывает только те значения, которые соответствуют нескольким условиям

Функция ЕСЛИМН (Office 365, Excel 2016 и более поздние версии)

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Математические и тригонометрические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

СУММЕСЛИ в Excel с динамическим условием

Функции СУММЕСЛИ и СУММЕСЛИМН хороши тем, что они автоматически подстраиваются под изменение условий. Т.е. мы можем изменить данные в ячейках, и суммы будут изменяться вместе с ними. Например, при подсчете заработных плат оказалось, что мы забыли учесть одну сотрудницу, которая работает продавцом. Мы можем добавить еще одну строчку через правую кнопку мыши и команду ВСТАВИТЬ.

У нас появилась дополнительная строчка. Сразу обращаем внимание, что диапазон условий и суммирования автоматически расширился до 15 строки.

funkcii-excel16-3.png

Копируем данные сотрудника и вставляем их в общий перечень. Суммы в итоговых ячейках изменились. Функции среагировали на появление в диапазоне еще одного продавца-женщины.

funkcii-excel16-4.png

Аналогично можно не только добавлять, но и удалять какие-либо строки (например, при увольнении сотрудника), изменять значения (заменить «январь» на «февраль» и подставить новые заработные платы) и т.п.

Альтернативный вариант

​Диапазон_суммирования​СУММЕСЛИ​СУММ​

​В этом уроке мы​ в определенный интервал,​А​ двумя столбцами (полями):​ критерий объединить несколько​

excel-summeslimn_4_1.png

​ «>=100» или «<>0»),​ отгрузках трех товаров​ которые указываются в​ при помощи формулы​ памятью.​

Источники

  • https://exceltable.com/formuly/summesli-s-neskolkimi-usloviyami
  • https://naprimerax.org/posts/68/funktciia-summesli-v-excel
  • https://excel2.ru/articles/funkciya-summeslimn-slozhenie-s-neskolkimi-kriteriyami-v-ms-excel-chast-2uslovie-i-summeslimn
  • https://geekon.media/funkciya-summesli-v-excel/
  • https://www.planetaexcel.ru/techniques/2/167/
  • https://excelhack.ru/kak-summirovat-znacheniya-mezhdu-dvumya-datami/
  • https://exceltable.com/funkcii-excel/funkciya-summesli-v-excel-primery
  • https://my-excel.ru/excel/summesli-v-excel-po-dvum-kriterijam.html
Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...