Как в excel подсчитать количество ячеек со значением

Считаем количество значений в Excel, количество чисел, количество строк и столбцов, считать значения с одним условием, с несколькими условиями, функции Эксель

Примеры работы функции СЧЕТЕСЛИ.

Для подсчета текста.

Давайте разбираться, как это работает. На рисунке ниже вы видите список заказов, выполненных менеджерами. Выражение  =СЧЕТЕСЛИ(В2:В22,”Никитенко”) подсчитывает, сколько раз этот работник присутствует в списке:

Замечание. Критерий не чувствителен к регистру букв, поэтому можно вводить как прописные, так и строчные буквы.

Если ваши данные содержат несколько вариантов слов, которые вы хотите сосчитать, то вы можете использовать подстановочные знаки для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть их содержимого.

К примеру, в нашей таблице есть несколько заказчиков «Корона» из разных городов. Нам необходимо подсчитать общее количество заказов «Корона» независимо от города.

=СЧЁТЕСЛИ(A2:A22;”*Коро*”)

Мы подсчитали количество заказов, где в наименовании заказчика встречается «коро» в любом регистре. Звездочка (*) используется для поиска ячеек с любой последовательностью начальных и конечных символов, как показано в приведенном выше примере. Если вам нужно заменить какой-либо один символ, введите вместо него знак вопроса (?).

Кроме того, указывать условие прямо в формуле не совсем рационально, так как при необходимости подсчитать какие-то другие значения вам придется корректировать её. А это не слишком удобно.

Рекомендуется условие записывать в какую-либо ячейку и затем ссылаться на нее. Так мы сделали в H9. Также можно употребить подстановочные знаки со ссылками с помощью оператора конкатенации (&). Например, вместо того, чтобы указывать «* Коро *» непосредственно в формуле, вы можете записать его куда-нибудь, и использовать следующую конструкцию для подсчета ячеек, содержащих «Коро»:

=СЧЁТЕСЛИ(A2:A22;”*”&H8&”*”)

Подсчет ячеек, начинающихся или заканчивающихся определенными символами

Вы можете употребить подстановочный знак звездочку (*) или знак вопроса (?) в зависимости от того, какого именно результата вы хотите достичь.

Если вы хотите узнать количество ячеек, которые начинаются или заканчиваются определенным текстом, независимо от того, сколько имеется других символов, используйте:

=СЧЁТЕСЛИ(A2:A22;”К*”) – считать значения, которые начинаются с « К» .

=СЧЁТЕСЛИ(A2:A22;”*р”) – считать заканчивающиеся буквой «р».

Если вы ищете количество ячеек, которые начинаются или заканчиваются определенными буквами и содержат точное количество символов, то поставьте вопросительный знак (?):

=СЧЁТЕСЛИ(С2:С22;”????д”) – находит количество буквой «д» в конце и текст в которых состоит из 5 букв, включая пробелы.

= СЧЁТЕСЛИ(С2:С22,”??”) – считает количество состоящих из 2 символов, включая пробелы.

Примечание. Чтобы узнать количество клеток, содержащих в тексте знак вопроса или звездочку, введите тильду (~) перед символом ? или *.

Например, = СЧЁТЕСЛИ(С2:С22,”*~?*”) будут подсчитаны все позиции, содержащие знак вопроса в диапазоне С2:С22.

Подсчет чисел по условию.

В отношении чисел редко случается, что нужно подсчитать количество их, равных какому-то определённому числу. Тем не менее, укажем, что записать нужно примерно следующее:

= СЧЁТЕСЛИ(D2:D22,10000)

Гораздо чаще нужно высчитать количество значений, больших либо меньших определенной величины.

Чтобы подсчитать значения, которые больше, меньше или равны указанному вами числу, вы просто добавляете соответствующий критерий, как показано в таблице ниже.

Обратите внимание, что математический оператор вместе с числом всегда заключен в кавычки .

критерии

 

Описание

Если больше, чем

=СЧЕТЕСЛИ(А2:А10;”>5″)

Подсчитайте, где значение больше 5.

Если меньше чем

=СЧЕТЕСЛИ(А2:А10;”>5″)

Подсчет со числами менее 5.

Если равно

=СЧЕТЕСЛИ(А2:А10;”=5″)

Определите, сколько раз значение равно 5.

Если не равно

=СЧЕТЕСЛИ(А2:А10;”<>5″)

Подсчитайте, сколько раз не равно 5.

Если больше или равно

=СЧЕТЕСЛИ(А2:А10;”>=5″)

Подсчет, когда больше или равно 5.

Если меньше или равно

=СЧЕТЕСЛИ(А2:А10;”<=5″)

Подсчет, где меньше или равно 5.

В нашем примере

=СЧЁТЕСЛИ(D2:D22;”>10000″)

Считаем количество крупных заказов на сумму более 10 000. Обратите внимание, что условие подсчета мы записываем здесь в виде текстовой строки и поэтому заключаем его в двойные кавычки.

Вы также можете использовать все вышеприведенные варианты для подсчета ячеек на основе значения другой ячейки. Вам просто нужно заменить число ссылкой.

Замечание. В случае использования ссылки, вы должны заключить математический оператор в кавычки и добавить амперсанд (&) перед ним. Например, чтобы подсчитать числа в диапазоне D2: D9, превышающие D3, используйте =СЧЕТЕСЛИ(D2:D9,”>”&D3)

Если вы хотите сосчитать записи, которые содержат математический оператор, как часть их содержимого, то есть символ «>», «<» или «=», то употребите в условиях подстановочный знак с оператором. Такие критерии будут рассматриваться как текстовая строка, а не числовое выражение.

Например, =СЧЕТЕСЛИ(D2:D9,”*>5*”) будет подсчитывать все позиции в диапазоне D2: D9 с таким содержимым, как «Доставка >5 дней» или «>5 единиц в наличии».

Примеры с датами.

Если вы хотите сосчитать клетки с датами, которые больше, меньше или равны указанной вами дате, вы можете воспользоваться уже знакомым способом, используя формулы, аналогичные тем, которые мы обсуждали чуть выше. Все вышеприведенное работает как для дат, так и для чисел.

Позвольте привести несколько примеров:

критерии

 

Описание

Даты, равные указанной дате.

=СЧЕТЕСЛИ(E2:E22;”01.02.2019″)

Подсчитывает количество ячеек в диапазоне E2:E22 с датой 1 июня 2014 года.

Даты больше или равные другой дате.

=СЧЕТЕСЛИ(E2:E22,”>=01.02.2019″)

Сосчитайте количество ячеек в диапазоне E2:E22 с датой, большей или равной 01.06.2014.

Даты, которые больше или равны дате в другой ячейке, минус X дней.

=СЧЕТЕСЛИ(E2:E22,”>=”&H2-7)

Определите количество ячеек в диапазоне E2:E22 с датой, большей или равной дате в H2, минус 7 дней.

Помимо этих стандартных способов, вы можете употребить функцию СЧЕТЕСЛИ в сочетании с функциями даты и времени, например, СЕГОДНЯ(), для подсчета ячеек на основе текущей даты.

критерии

 

Равные текущей дате.

=СЧЕТЕСЛИ(E2:E22;СЕГОДНЯ())

До текущей даты, то есть меньше, чем сегодня.

=СЧЕТЕСЛИ(E2:E22;”<“&СЕГОДНЯ())

После текущей даты, т.е. больше, чем сегодня.

=СЧЕТЕСЛИ(E2:E22;”>”& ЕГОДНЯ ())

Даты, которые должны наступить через неделю.

= СЧЕТЕСЛИ(E2:E22,”=”&СЕГОДНЯ()+7)

В определенном диапазоне времени.

=СЧЁТЕСЛИ(E2:E22;”>=”&СЕГОДНЯ()+30)-СЧЁТЕСЛИ(E2:E22;”>”&СЕГОДНЯ())

Процедура подсчета значений в столбце

В зависимости от целей пользователя, в Экселе можно производить подсчет всех значений в столбце, только числовых данных и тех, которые соответствуют определенному заданному условию. Давайте рассмотрим, как решить поставленные задачи различными способами.

Способ 1: индикатор в строке состояния

Данный способ самый простой и требующий минимального количества действий. Он позволяет подсчитать количество ячеек, содержащих числовые и текстовые данные. Сделать это можно просто взглянув на индикатор в строке состояния.

Для выполнения данной задачи достаточно зажать левую кнопку мыши и выделить весь столбец, в котором вы хотите произвести подсчет значений. Как только выделение будет произведено, в строке состояния, которая расположена внизу окна, около параметра «Количество» будет отображаться число значений, содержащихся в столбце. В подсчете будут участвовать ячейки, заполненные любыми данными (числовые, текстовые, дата и т.д.). Пустые элементы при подсчете будут игнорироваться.

Количество значений в столбце отображаемое на строке состояния в Microsoft Excel

В некоторых случаях индикатор количества значений может не высвечиваться в строке состояния. Это означает то, что он, скорее всего, отключен. Для его включения следует кликнуть правой кнопкой мыши по строке состояния. Появляется меню. В нем нужно установить галочку около пункта «Количество». После этого количество заполненных данными ячеек будет отображаться в строке состояния.

Включение индикатора количества на строке состояния в Microsoft Excel

К недостаткам данного способа можно отнести то, что полученный результат нигде не фиксируется. То есть, как только вы снимете выделение, он исчезнет. Поэтому, при необходимости его зафиксировать, придется записывать полученный итог вручную. Кроме того, с помощью данного способа можно производить подсчет только всех заполненных значениями ячеек и нельзя задавать условия подсчета.

Способ 2: оператор СЧЁТЗ

С помощью оператора СЧЁТЗ, как и в предыдущем случае, имеется возможность подсчета всех значений, расположенных в столбце. Но в отличие от варианта с индикатором в панели состояния, данный способ предоставляет возможность зафиксировать полученный результат в отдельном элементе листа.

Главной задачей функции СЧЁТЗ, которая относится к статистической категории операторов, как раз является подсчет количества непустых ячеек. Поэтому мы её с легкостью сможем приспособить для наших нужд, а именно для подсчета элементов столбца, заполненных данными. Синтаксис этой функции следующий:

=СЧЁТЗ(значение1;значение2;…)

Всего у оператора может насчитываться до 255 аргументов общей группы «Значение». В качестве аргументов как раз выступают ссылки на ячейки или диапазон, в котором нужно произвести подсчет значений.

  1. Выделяем элемент листа, в который будет выводиться итоговый результат. Щелкаем по значку «Вставить функцию», который размещен слева от строки формул.

Переход в Мастер функций в Microsoft Excel

Тем самым мы вызвали Мастер функций. Переходим в категорию «Статистические» и выделяем наименование «СЧЁТЗ». После этого производим щелчок по кнопке «OK» внизу данного окошка.

Переход в окно аргументов функции СЧЁТЗ в Microsoft Excel

Мы переходим к окну аргументов функции СЧЁТЗ. В нём располагаются поля ввода аргументов. Как и количество аргументов, они могут достигать численности 255 единиц. Но для решения поставленной перед нами задачи хватит и одного поля «Значение1». Устанавливаем в него курсор и после этого с зажатой левой кнопкой мыши выделяем на листе тот столбец, значения в котором нужно подсчитать. После того, как координаты столбца отобразились в поле, жмем на кнопку «OK» в нижней части окна аргументов.

Окно аргументов функции СЧЁТЗ в Microsoft Excel

Программа производит подсчет и выводит в ячейку, которую мы выделяли на первом шаге данной инструкции, количество всех значений (как числовых, так и текстовых), содержащихся в целевом столбце.

Результат вычисления функции СЧЁТЗ в Microsoft Excel

Как видим, в отличие от предыдущего способа, данный вариант предлагает выводить результат в конкретный элемент листа с возможным его сохранением там. Но, к сожалению, функция СЧЁТЗ все-таки не позволяет задавать условия отбора значений.

Урок: Мастер функций в Excel

Способ 3: оператор СЧЁТ

С помощью оператора СЧЁТ можно произвести подсчет только числовых значений в выбранной колонке. Он игнорирует текстовые значения и не включает их в общий итог. Данная функция также относится к категории статистических операторов, как и предыдущая. Её задачей является подсчет ячеек в выделенном диапазоне, а в нашем случае в столбце, который содержит числовые значения. Синтаксис этой функции практически идентичен предыдущему оператору:

=СЧЁТ(значение1;значение2;…)

Как видим, аргументы у СЧЁТ и СЧЁТЗ абсолютно одинаковые и представляют собой ссылки на ячейки или диапазоны. Различие в синтаксисе заключается лишь в наименовании самого оператора.

  1. Выделяем элемент на листе, куда будет выводиться результат. Нажимаем уже знакомую нам иконку «Вставить функцию».

Переход в Мастер функций в программе Microsoft Excel

После запуска Мастера функций опять перемещаемся в категорию «Статистические». Затем выделяем наименование «СЧЁТ» и щелкаем по кнопке «OK».

Переход в окно аргументов функции СЧЁТ в Microsoft Excel

После того, как было запущено окно аргументов оператора СЧЁТ, следует в его поле внести запись. В этом окне, как и в окне предыдущей функции, тоже может быть представлено до 255 полей, но, как и в прошлый раз, нам понадобится всего одно из них под названием «Значение1». Вводим в это поле координаты столбца, над которым нам нужно выполнить операцию. Делаем это все тем же образом, каким выполняли данную процедуру для функции СЧЁТЗ: устанавливаем курсор в поле и выделяем колонку таблицы. После того, как адрес столбца был занесен в поле, жмем на кнопку «OK».

Окно аргументов функции СЧЁТ в Microsoft Excel

Результат тут же будет выведен в ячейку, которую мы определили для содержания функции. Как видим, программа подсчитала только ячейки, которые содержат числовые значения. Пустые ячейки и элементы, содержащие текстовые данные, в подсчете не участвовали.

Урок: Функция СЧЁТ в Excel

Способ 4: оператор СЧЁТЕСЛИ

В отличие от предыдущих способов, использование оператора СЧЁТЕСЛИ позволяет задавать условия, отвечающие значения, которые будут принимать участие в подсчете. Все остальные ячейки будут игнорироваться.

Оператор СЧЁТЕСЛИ тоже причислен к статистической группе функций Excel. Его единственной задачей является подсчет непустых элементов в диапазоне, а в нашем случае в столбце, которые отвечают заданному условию. Синтаксис у данного оператора заметно отличается от предыдущих двух функций:

=СЧЁТЕСЛИ(диапазон;критерий)

Аргумент «Диапазон» представляется в виде ссылки на конкретный массив ячеек, а в нашем случае на колонку.

Аргумент «Критерий» содержит заданное условие. Это может быть как точное числовое или текстовое значение, так и значение, заданное знаками «больше» (>), «меньше» (<), «не равно» (<>) и т.д.

Посчитаем, сколько ячеек с наименованием «Мясо» располагаются в первой колонке таблицы.

  1. Выделяем элемент на листе, куда будет производиться вывод готовых данных. Щелкаем по значку «Вставить функцию».

Вставить функцию в Microsoft Excel

В Мастере функций совершаем переход в категорию «Статистические», выделяем название СЧЁТЕСЛИ и щелкаем по кнопке «OK».

Переход в окно аргументов функции СЧЁТЕСЛИ в Microsoft Excel

Производится активация окошка аргументов функции СЧЁТЕСЛИ. Как видим, окно имеет два поля, которые соответствуют аргументам функции.

В поле «Диапазон» тем же способом, который мы уже не раз описывали выше, вводим координаты первого столбца таблицы.

В поле «Критерий» нам нужно задать условие подсчета. Вписываем туда слово «Мясо».

После того, как вышеуказанные настройки выполнены, жмем на кнопку «OK».

Окно аргументов функции СЧЁТЕСЛИ в Microsoft Excel

Оператор производит вычисления и выдает результат на экран. Как видим, в выделенной колонке в 63 ячейках содержится слово «Мясо».

Результат вычисления функции СЧЁТЕСЛИ в Microsoft Excel

Давайте немного изменим задачу. Теперь посчитаем количество ячеек в этой же колонке, которые не содержат слово «Мясо».

  1. Выделяем ячейку, куда будем выводить результат, и уже описанным ранее способом вызываем окно аргументов оператора СЧЁТЕСЛИ.

    В поле «Диапазон» вводим координаты все того же первого столбца таблицы, который обрабатывали ранее.

    В поле «Критерий» вводим следующее выражение:

    <>Мясо

    То есть, данный критерий задает условие, что мы подсчитываем все заполненные данными элементы, которые не содержат слово «Мясо». Знак «<>» означает в Экселе «не равно».

    После введения этих настроек в окне аргументов жмем на кнопку «OK».

Окно аргументов функции СЧЁТЕСЛИ в программе Microsoft Excel

В предварительно заданной ячейке сразу же отображается результат. Он сообщает о том, что в выделенном столбце находятся 190 элементов с данными, которые не содержат слово «Мясо».

Результат вычисления функции СЧЁТЕСЛИ в программе Microsoft Excel

Теперь давайте произведем в третьей колонке данной таблицы подсчет всех значений, которые больше числа 150.

  1. Выделяем ячейку для вывода результата и производим переход в окно аргументов функции СЧЁТЕСЛИ.

    В поле «Диапазон» вводим координаты третьего столбца нашей таблицы.

    В поле «Критерий» записываем следующее условие:

    >150

    Это означает, что программа будет подсчитывать только те элементы столбца, которые содержат числа, превышающие 150.

    Далее, как всегда, жмем на кнопку «OK».

Подсчет значений больше 50 в окне аргументов функции СЧЁТЕСЛИ в Microsoft Excel

После проведения подсчета Excel выводит в заранее обозначенную ячейку результат. Как видим, выбранный столбец содержит 82 значения, которые превышают число 150.

Результат подсчета значений больше 50 функцией СЧЁТЕСЛИ в Microsoft Excel

Таким образом, мы видим, что в Excel существует целый ряд способов подсчитать количество значений в столбце. Выбор определенного варианта зависит от конкретных целей пользователя. Так, индикатор на строке состояния позволяет только посмотреть количество всех значений в столбце без фиксации результата; функция СЧЁТЗ предоставляет возможность их число зафиксировать в отдельной ячейке; оператор СЧЁТ производит подсчет только элементов, содержащих числовые данные; а с помощью функции СЧЁТЕСЛИ можно задать более сложные условия подсчета элементов.

ЗакрытьМы рады, что смогли помочь Вам в решении проблемы.
ЗакрытьОпишите, что у вас не получилось.

Наши специалисты постараются ответить максимально быстро.

Помогла ли вам эта статья?

ДА НЕТ

Разные значения против уникальных значений

Кажется, что это одно и то же, но это не так.

Ниже приведен пример со списком имен, в столбцах отдельно выделены уникальные и разные имена.

screenshot_1-8.pngРазница между уникальным и разными значениями

Уникальные значения / имена — это те, которые встречаются только один раз. Это означает, что все имена, которые повторяются и имеют дубликаты, не являются уникальными. Уникальные имена перечислены в столбце D вышеупомянутого набора данных.

Разными значениями / именами являются те, которые встречаются хотя бы один раз в наборе данных. Поэтому, если имя появляется три раза, оно все равно считается разным значением. Такой список можно получить путем удаления повторяющихся значений / имен и сохранения всех разных значений. Разные имена перечислены в столбце C приведенного выше набора данных.

В большинстве случаев, когда люди говорят, что хотят получить уникальные значения в сводной таблице, когда на самом деле имеют в виду разные.

Как вызвать функцию СЧЁТЕСЛИ СЧЁТЕСЛИ в MS Excel.

Нажимаем на кнопу Вставить функцию и в открывшемся диалоговом окне Вставка функции, в поле поиск, пишем СЧЁТЕСЛИ. Нажимаем найти. Обращаю внимание, что в поле поиска, писать СЧЁТЕЛСИ, необходимо именно с буквой Ё. По-другому поиск не найдет интересующую нас функцию. По результатам поиска, выбираем нужную нам функцию.

Функция СЧЁТЕСЛИ в MS Excel. Описание и примеры

Синтаксис:

СЧЁТ(аргумент1;[аргумент2];…)

Аргументы функции СЧЁТ():

  • Аргумент1 — обязательный. Первый элемент, ссылка на ячейку или диапазон, для которого требуется подсчитать количество чисел.
  • Аргумент2 (до 255 дополнительных аргументов) — необязательный аргумент.

Аргументы могут содержать данные различных типов или ссылаться на них, но при подсчете учитываются только числа. Например, нужно подсчитать количество чисел в диапазоне A1:A10, формула будет СЧЁТ(A1:A10). В конкретном примере всего 1 аргумент — это диапазон, ячейки которого состоят в том числе и из текста:

Как подсчитать количество чисел в Excel? Функция СЧЁТ() 1

Рассмотрим подробнее, как так получилось, что дата — это число? Ответ можно найти в описании функции ТИП(). Строка password00 не является числом,  так как состоит из букв и чисел, в таком случае это считается как текст. В информационных технологиях понятие текст часто аналогично слову строка (string).

Внимание! Если в аргументах ссылаться на ячейку с логическим выражением, то СЧЁТ не посчитает её за число, а если в аргументах — посчитает. Например, в ячейку A10 мы пишем =ИСТИНА, далее в другой ячейке указываем =СЧЁТ(A10), результатом будем 0, а если написать =СЧЁТ(ИСТИНА), функция вернёт 1.

Суммирование ячеек по цвету

Для начала перейдем в редактор VBA, для этого в панели вкладок выбираем Разработчик -> Visual Basic (или нажимаем комбинацию клавиш Alt + F11).

Создаем новый модуль и добавляем в него следующий код функции для суммы (напротив каждой строчки дается пояснение к коду):

PublicFunctionСУММЦВЕТ(MyRange AsRange,MyCell AsRange)AsDouble

    DimSum AsDouble‘Ввод переменной Sum для подсчета суммы

    Sum=0‘Приравнивание переменной Sum к нулю

    Application.Volatile True‘Пересчет функции при каком-либо изменении значений ячеек листа

    ForEachcell InMyRange‘Цикл по всем ячейкам диапазона

        Ifcell.Interior.Color=MyCell.Interior.Color Then‘Проверка текущей ячейки на условие по цвету

            Sum=Sum+cell.Value‘Значение текущей ячейки прибавляется к промежуточной сумме

        EndIf

    Next

    СУММЦВЕТ=Sum‘Приравнивание возвращаемому результату значения конечной суммы

EndFunction

Функция СУММЦВЕТ содержит два аргумента:

  • MyRange (обязательный аргумент) — диапазон ячеек для суммирования;
  • MyCell (обязательный аргумент) — ячейка, по цвету заливки которой рассчитывается сумма.

Функция СУММЦВЕТ теперь будет определяться при вводе формулы в ячейку, переходим из редактора на лист Excel и, чтобы просуммировать ячейки воспользуемся новой функцией:

Функции количества и суммы ячеек по цвету

Как мы видим, в итоге для каждого определенного цвета ячейки мы получили различный результат.

При этом, если выбранная ячейка не имеет заливки, то функция суммы и подсчета количества ячеек по выбранному цвету также будет работать.

Как выполнить подсчёт ячеек со значением

Здравствуйте, дорогие читатели.

Перед началом данной темы я бы хотел вам посоветовать отличный обучающий продукт по теме экселя, по названием « Неизвестный Excel » , там всё качественно и понятно изложено. Рекомендую.

Ну а теперь вернёмся к теме.

Вы наверняка являетесь представителем одной из профессий, в которой не обойтись без программы эксель. Ведь она позволяет вести подсчеты, составлять списки, таблицы и диаграммы, заполнять ежедневники и решать многие другие задачи, связанные с цифрами.

Однако не все, кто работает с этим приложением, знает его полную функциональность и умеет ее применять на практике. Вы один из них? Тогда вы обратились по адресу. В частности, сегодня мы разберем, как в excel подсчитать количество ячеек со значением. Есть несколько способов, как это сделать. Они зависят от того, какое именно содержимое вам нужно посчитать. Разберем самые популярные из них.

Метод 2: применение функции СЧЕТЗ

Данная функция позволяет сделать то же самое, но с одной существенной разницей – полученный результат будет зафиксирован. Остальные минусы предыдущего метода сохраняются, т.е. СЧЕТ3 не работает с условиями.

Функция СЧЕТ3 выполняет задачу по подсчету всех заполненных ячеек в заданном диапазоне (пустые не учитываются). Формула функции может выглядет по-разному:

  • =СЧЕТЗ(ячейка1;ячейка2;…ячейкаN)
  • =СЧЕТЗ(ячейка1:ячейкаN)

В первом случае функция выполнит подсчет всех перечисленных ячеек. Во втором – определит количество непустых ячеек в диапазоне от ячейки 1 до ячейки N. Обратите внимание, что количество аргументов функции ограничено на отметке 255.

Давайте попробуем применить функцию СЧЕТ3 на примере:

  1. Выбираем ячейку, где по итогу будет выведен результат подсчета.
  2. Переходим во вкладку “Формулы” и нажимаем кнопку “Вставить функцию”.Применение функции СЧЕТЗТакже можно кликнуть по значку «Вставить функцию» рядом со строкой формул.Применение функции СЧЕТЗ
  3. В открывшемся меню (Мастер функций) выбираем категорию «Статистические», далее ищем в перечне нужную функцию СЧЕТ3, выбираем ее и нажимаем OK, чтобы приступить к ее настройке.Применение функции СЧЕТЗ
  4. В окне «Аргументы функции» задаем нужные ячейки (перечисляя их или задав диапазон) и щелкаем по кнопке OK. Задать диапазон можно как с заголовком, так и без него.Применение функции СЧЕТЗ
  5. Результат подсчет будет отображен в выбранной нами ячейке, что изначально и  требовалось. Учтены все ячейки с любыми данными (за исключением пустых).Применение функции СЧЕТЗ

Функция СЧЕТ подойдет, если вы работаете исключительно с числами. Ячейки, заполненные текстовыми значениями, этой функцией учитываться не будут. В остальном СЧЕТ почти идентичен СЧЕТЗ из ранее рассмотренного метода.

Так выглядит формула функции СЧЕТ:

  • =СЧЕТ(ячейка1;ячейка2;…ячейкаN)
  • =СЧЕТ(ячейка1:ячейкаN)

Алгоритм действий также похож на тот, что мы рассмотрели выше:

  1. Выбираем ячейку, где будет сохранен и отображен результат подсчета значений.
  2. Заходим в Мастер функций любым удобным способом, выбираем в категории “Статистические” необходимую строку СЧЕТ и щелкаем OK.Использование функции СЧЕТ
  3. В «Аргументах функции» задаем диапазон ячеек или перечисляем их. Далее жмем OK.Использование функции СЧЕТ
  4. В выбранной ячейке будет выведен результат. Функция СЧЕТ проигнорирует все ячейки с пустым содержанием или с текстовыми значениями. Таким образом, будет произведен подсчет исключительно тех ячеек, которые содержат числовые данные.Использование функции СЧЕТ

Подсчет Уникальных ТЕКСТовых значений в MS EXCEL

К примеру, рассмотрим следующую табличку:

kak-poschitat-kolichestvo-znachenij-v-stolbce-excel-6-sposobov-podscheta-kolichestva-znachenij-v-stolbce-ehksel25

Цель: посчитать число уникальных текстовых показателей в А7:А15. Для этого мы применяем формулу: =СУММПРОИЗВ((А7:А15<>»»)/СЧЕТЕСЛИ(А7:А15;А7:А15)).

Если в указанных координатах присутствуют и числовые показатели, то они тоже будут подсчитаны. Для того чтобы подсчет чисел не производился, необходимо использовать: =СУММПРОИЗВ(ЕТЕКСТ(А7:А15)/СЧЕТЕСЛИ(А7:А15;А7:А15)).

Как найти повторяющиеся значения в Excel.

К примеру, у нас есть следующая табличка:

kak-poschitat-kolichestvo-znachenij-v-stolbce-excel-6-sposobov-podscheta-kolichestva-znachenij-v-stolbce-ehksel26

Для подсчета повторяющихся значений необходимо ввести следующую формулу в G5: =ЕСЛИ(СЧЕТЕСЛИ(А$5:А$10;А5)>1;СЧЕТЕСЛИ(А$5:А5;А5);1). Затем необходимо скопировать эту формулу на всю колонку.

Как определить наиболее часто встречающееся число

Чтобы найти число, которое чаще всего встречается в массиве, есть в Эксель функция МОДА(число1;число2;…). Результатом её выполнение будет то самое число, которое встречается чаще всего. Чтобы определить их количество — можно воспользоваться комбинацией формул суммирования и формул массива.

Если таких чисел несколько – будет выведено то, которое раньше других встречается в списке. Функция работает только с числовыми данными.

Часто встречающееся число в ЭксельЧасто встречающееся число

Вот, пожалуй и весь список функций, который я хочу вам презентовать в рамках этого поста. Их вполне достаточно, чтобы решить самые популярные задачи счёта ячеек. Комбинируйте их с другими функциями (например, текстовыми, даты и времени), чтобы получить максимальный результат.

В следующей статье мы изучим функции суммирования. Заходите почитать, даже если уверены, что всё об этом знаете. Думаю, там буде кое-что именно для вас!

Подсчет количества определенного значения ячейки в Excel при условии

Рассмотрим этот момент на конкретном примере. Допустим, у нас есть следующая табличка для работы:

kak-poschitat-kolichestvo-znachenij-v-stolbce-excel-6-sposobov-podscheta-kolichestva-znachenij-v-stolbce-ehksel28

Выделяем диапазон Е2:Е5 и вводим формулу: =СЧЕТЕСЛИ(B3:B19;D2:D5). В3:В19 – ячейки, содержащие оценки, а D2:D5 – ячейки, в которых располагаются критерии для подсчета количества соответствий. В итоге мы получаем такой результат:

kak-poschitat-kolichestvo-znachenij-v-stolbce-excel-6-sposobov-podscheta-kolichestva-znachenij-v-stolbce-ehksel29

ВПР

Формула: =ВПР(искомое_значение; таблица; номер_столбца; тип_совпадения)

Англоязычный вариант: =VLOOKUP (искомое_значение; таблица; номер_столбца; тип_совпадения)

Функция ВПР работает как телефонная книга, где по фрагменту известных данных – имени, вы находите неизвестные сведения – номер телефона. В формуле необходимо задать искомое значение, которое формула должна найти в столбце таблицы.

Например, у вас есть два списка: первый с паспортными данными сотрудников и их доходами от продаж за последний квартал, а второй – с их паспортными данными и именами. Вы хотите сопоставить имена с доходами от продаж, но, делая это вручную, можно легко ошибиться.

  1. В первом списке данные записаны с А1 по В13, во втором – с D1 по Е13.
  2. В ячейке B17 поставим формулу: =ВПР(B16; A1:B13; 2; ЛОЖЬ)
  • B16 = искомое значение, то есть паспортные данные. Они имеются в обоих списках.
  • A1:B13 = таблица, в которой находится искомое значение.
  • 2 – номер столбца, где находится искомое значение.
  • ЛОЖЬ – логическое значение, которое означает то, что вам требуется точное совпадение возвращаемого значения. Если вам достаточно приблизительного совпадения, указываете ИСТИНА, оно также является значением по умолчанию.

Эта формула не такая простая, как предыдущие, тем не менее она очень полезна в работе.

Счёт текстовых строк по условию

Похожее задание, но теперь нужно считать, сколько менеджеров продавали товар с кодом 1001.

А формула такая:

=СУММ(—(ЧАСТОТА(ЕСЛИ(диапазон<>»»;ЕСЛИ(условие>;ПОИСКПОЗ(диапазон>; диапазон>;0)));СТРОКА(диапазон)-СТРОКА(диапазон.первая ячейка)+1)>0))

Вот так можно организовать подсчет одинаковых значений в столбце Excel в самых распространенных случаях. Формулы универсальные, скопируйте их, вставьте свои данные и получите результат.

Источники

  • https://excelpedia.ru/bez-rubriki/podschet-raznih-znachenii-v-svodnoi-tablice-excel
  • https://exceltable.com/funkcii-excel/primery-funkcii-schetesli
  • https://lumpics.ru/how-count-number-of-filled-cells-in-excel/
  • https://mister-office.ru/funktsii-excel/function-countif.html
  • https://profi-user.ru/podschet-yacheek/
  • https://officelegko.com/2019/09/19/podschet-unikalnyh-znachenij-v-excel/
Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...