Как объединить ячейки в Google Таблицах – Autotak

В этой статье вы найдете инструкцию по работе с ячейками в Google Таблицах: вставка и удаление, выделение диапазонов, изменение размеров, объединение ячеек.

1. Объединение, скрытие, замена

Пусть требуется получить отчет следующего вида


Этот отчет имеет несколько особенностей:
– Объединенные ячейки в шапке
 – Количество и состав колонок в группе “Бонусы” – динамические. Выводятся только, если заполнено хотя бы для одного сотрудника в отчете. Если, например, никто из попавших в отчет сотрудников не получил надбавку за сверхурочные, то этой колонки в отчете быть не должно. Проектов в группе “за проекты” может быть неограниченное количество.
– Дополнительные требования к порядку полей: колонка “Оклад” должна выводиться первой, “Всего по сотруднику” – последней

В консоли можно получить следующий результат


Далее приведены универсальные процедуры, с помощью которых можно:
1. Объединить ячейки “Бонусы” и “За проекты” в шапке отчета с помощью процедуры ОбъединтьЯчейкиВТабличномДокументе()
2. Скрыть заголовок ресурса “Сумма” с помощью процедуры СкрытьСтрокиВТабличномДокументе()

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ВывестиСКДВТабличныйДокумент(СхемаКомпоновкиДанных, ДокументРезультат, КомпоновщикНастроек); Маркер = “Бонусы”; ОбъединитьЯчейкиВТабличномДокументе(ДокументРезультат, Маркер); Маркер = “За проекты”; ОбъединитьЯчейкиВТабличномДокументе(ДокументРезультат, Маркер); Маркер = “Сумма”; СкрытьСтрокиВТабличномДокументе(ДокументРезультат, Маркер);КонецПроцедурыПроцедура ОбъединитьЯчейкиВТабличномДокументе(ТабличныйДокумент, МаркерОбъединения) Экспорт // Находит ячейки, содержащие в тексте МаркерОбъединения // Объединяет ячейки, располагающиеся рядом, содержащие одинаковый текст и маркер объединения ОбъединяемыеЯчейки = НайтиОбластиТабличногоДокументаПоВхождениюПодстроки(ТабличныйДокумент, МаркерОбъединения); ОбъединяемыеЯчейки.Колонки.Добавить(“Диапазон”); ОбъединяемыеЯчейки.Сортировать(“Верх,Лево”); Для Каждого Строка из ОбъединяемыеЯчейки Цикл Отбор = Новый Структура(“Текст,Верх,Лево”, Строка.Текст, Строка.Верх-1, Строка.Лево); НайденныеСтроки = ОбъединяемыеЯчейки.НайтиСтроки(Отбор); Если НайденныеСтроки.Количество() Тогда Строка.Диапазон = НайденныеСтроки[0].Диапазон; Строка.Диапазон.Низ = Макс(Строка.Диапазон.Низ, Строка.Верх); Продолжить; КонецЕсли; Отбор = Новый Структура(“Текст,Верх,Лево”, Строка.Текст, Строка.Верх, Строка.Лево-1); НайденныеСтроки = ОбъединяемыеЯчейки.НайтиСтроки(Отбор); Если НайденныеСтроки.Количество() Тогда Строка.Диапазон = НайденныеСтроки[0].Диапазон; Строка.Диапазон.Право = Макс(Строка.Диапазон.Право, Строка.Лево); Продолжить; КонецЕсли; Строка.Диапазон = Новый Структура(“Текст,Верх,Лево,Низ,Право”, Строка.Текст, Строка.Верх, Строка.Лево, Строка.Верх, Строка.Лево); КонецЦикла; ОбъединяемыеЯчейки.Свернуть(“Диапазон”); Для Каждого Строка Из ОбъединяемыеЯчейки Цикл Диапазон = Строка.Диапазон; Область = ТабличныйДокумент.Область(Диапазон.Верх, Диапазон.Лево, Диапазон.Низ, Диапазон.Право); Область.Объединить(); КонецЦикла; КонецПроцедурыПроцедура ЗаменитьТекстВТабличномДокументе(ТабличныйДокумент, ПодстрокаПоиска, ПодстрокаЗамены) Экспорт НайденныеОбласти = НайтиОбластиТабличногоДокументаПоВхождениюПодстроки(ТабличныйДокумент, ПодстрокаПоиска); Для каждого Строка из НайденныеОбласти Цикл Строка.Область.Текст = СтрЗаменить(Строка.Область.Текст, ПодстрокаПоиска, ПодстрокаЗамены); КонецЦикла; КонецПроцедурыПроцедура СкрытьСтрокиВТабличномДокументе(ТабличныйДокумент, МаркерУдаления) Экспорт НайденныеОбласти = НайтиОбластиТабличногоДокументаПоВхождениюПодстроки(ТабличныйДокумент, МаркерУдаления); НайденныеОбласти.Свернуть(“Верх”); Для каждого Строка из НайденныеОбласти Цикл Область = ТабличныйДокумент.Область(Строка.Верх, , Строка.Верх, ); Область.Видимость = Ложь; КонецЦикла; КонецПроцедурыФункция НайтиОбластиТабличногоДокументаПоВхождениюПодстроки(ТабличныйДокумент, ПодстрокаПоиска) Экспорт НайденныеОбласти = Новый ТаблицаЗначений; НайденныеОбласти.Колонки.Добавить(“Область”); НайденныеОбласти.Колонки.Добавить(“Текст”); НайденныеОбласти.Колонки.Добавить(“Верх”); НайденныеОбласти.Колонки.Добавить(“Лево”); НайденнаяОбласть = ТабличныйДокумент.НайтиТекст(ПодстрокаПоиска); Пока НЕ НайденнаяОбласть = Неопределено Цикл НоваяСтрока = НайденныеОбласти.Добавить(); ЗаполнитьЗначенияСвойств(НоваяСтрока, НайденнаяОбласть); НоваяСтрока.Область = НайденнаяОбласть; НайденнаяОбласть = ТабличныйДокумент.НайтиТекст(ПодстрокаПоиска, НайденнаяОбласть); КонецЦикла; Возврат НайденныеОбласти; КонецФункции

Как объединить ячейки в Google Таблицах

Предположим, у вас есть набор данных, показанный ниже, и вы хотите объединить строку заголовка с текстом «Store #».

Ниже приведены шаги по объединению этих ячеек:

Вышеупомянутые шаги объединят три ячейки и сделают их одной.

Другой способ получить доступ к параметрам слияния — использовать панель инструментов. Когда вы нажимаете значок «Объединить ячейки», он объединяет все ячейки. И если вы нажмете на выпадающий значок рядом с ним. он покажет другие параметры, такие как слияние по горизонтали или вертикали

ea2dce6f35a1e59f08c08b16f2a45b2c.png

Важное примечание : когда вы объединяете ячейки, в которых уже есть какое-то содержимое, последняя ячейка слияния сохранит только содержимое самой верхней левой ячейки. Остальное содержимое будет потеряно. К счастью, когда наступит такая ситуация, Google Sheets предупредит вас подсказкой (как показано ниже) и объединит ячейки только тогда, когда вы нажмете ОК.

Объединить несколько

Для объединения нескольких блоков выделите их и перейдите на вкладку «Формат» – «Объединить ячейки». Дальше нужно выбрать подходящий вариант.

Формат

Делать это лучше с пустой таблицей, в которую вы еще не успели ввести данные, поскольку после объединения в ячейке останется только та информация, что введена в верхний левый блок. Все остальное пропадет. Даже появится такое предупреждающее сообщение.

Внимание

Как видите, в примере объединив Фамилию, Имя и Отчество в ячейке осталась только Фамилия.

Объединили

Автор и редакторы

Автор: Влад Мержевич

Последнее изменение: 11.03.2020

Редакторы: Влад Мержевич

Назначение таблиц

Таблицы в HTML имеют две функции. Первая – это собственно таблицы, то есть вывод информации в видетаблицы. А вторая – это вёртска страницы. Отдельные части контента размещаются в разных ячейкахтаблицы и таким образом оказываются в нужном месте страницы. Табличная вёрстка устарела и почтине используется.

Действия

Выделить столбец Ctrl + Пробел

Выделить строку Shift + Пробел

Выделить все Ctrl + A

Отменить Ctrl + Z

Повторить Ctrl + Y

Ctrl + Shift + Z

Найти Ctrl + F

Найти и заменить Ctrl + H

Заполнить диапазон Ctrl + Ввод

Заполнить вниз Ctrl + D

Заполнить вправо Ctrl + R

Сохранить (все изменения сохраняются автоматически) Ctrl + S

Открыть Ctrl + O

Печать Ctrl + P

Копировать Ctrl + C

Вырезать Ctrl + X

Вставить Ctrl + V

Вставить только значения Ctrl + Shift + V

Показать краткий список быстрых клавиш Ctrl + /

Скрыть меню (компактный режим) Ctrl + Shift + F

Включить/отключить способы ввода (если вы используете алфавит, отличный от латинского) Ctrl + Shift + K

Выбрать инструменты ввода Ctrl + Alt + Shift + K

Как скрыть и открыть к видимости лист в Гугл таблицах

Листов в одном гугл документе бывает очень и очень много и не всегда они нужны нам видимыми. Ведь бывают листы с техническими данными, откуда мы, например, берем данные для своих выпадающих списков или еще какие-то данные, которые нам для ежедневной работы не нужны.
А если они нам не нужны, то зачем мы занимаем и без того драгоценное полезное пространство внизу документа? Правильно — незачем!
Давайте спрячем ненужные нам листы вместе:

  1. Кликаем по маленькому треугольнику на вкладке нужного нам листа
    скрытие листа в гугл документах
  2. Выбираем в выпавшем контекстном меню пункт «Скрыть лист»
    скрытие листа в гугл документах

И теперь для того чтобы показать скрытые листы необходимо пройти простой путь в меню:
Вид -> Скрытые листы -> Номер или название вашего листа:
unhide-list.jpg

Или же (что проще) нажать на иконку «Гамбургера» рядом с листами и найти там скрытый лист — название его будет полупрозрачным, давая нам понять что этот лист скрыт:
unhide-list-2.jpg

4. Установка собственного формата для табличного документа

Данная процедура является оберткой над стандартной процедурой СоздатьФорматСтрок() (постоянно приходится вспоминать, как она называется). Позволяет выводить одну таблицу под другой с независимой шириной колонок. В сводном примере данная процедура применяется для корректного форматирования конечного документа

Процедура ЗадатьФорматСтрокВТабличномДокументе(пТабличныйДокумент) // задает индивидуальный формат строк для табличного документа, сохраняя ширину колонок при выводе его в другой табличный документ пТабличныйДокумент.Область(1,,пТабличныйДокумент.ВысотаТаблицы).СоздатьФорматСтрок(); КонецПроцедуры

Процедуры тестировались на платформе 8.3 в режиме совместимости с 8.2 и без режима совмместимости, а также на платформе 8.1.

К статье прилагаются внешние отчеты со сводным примером (запускается в любой конфигурации 8.2/8.3 на обычных или управляемых формах, также отчет на 8.1) 

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Как убрать объединение ячеек в Excel

Можно воспользоваться последним пунктом из меню кнопки «Объединить ячейки».

Или можно снять галочку в окне форматирования.

ОБЪЕДИНЕННЫЕ ЯЧЕЙКИ

Для того, чтобы исправить проблему с объединенными ячейками, нужно просто узнать одну подробность: каждая ячейка имеет реквизиты «Лево», «Право», «Верх» и «Низ». И для объединенных ячеек они не будут равны. Для простого объединения по оси Х произвести чтение с учетом объединения будет достаточно просто:

Мы просто добавляем к «Х» «право» и вычитаем «лево».

А для оси «У» предлагаю разобраться самостоятельно (в качестве домашнего задания).

Перенос текста

Теперь давайте поговорим про текст, ведь таблица не всегда заполнена числами. Если введенное словосочетание не помещается по длине, тогда можно включить автоматический перенос текста в ячейке Гугл Таблицы.

Кликните мышкой по нужной ячейке и на панели инструментов выберите кнопку «Перенос текста». Затем нажмите по одному из предложенных вариантов. Найти данную кнопку можно и на вкладке «Формат».

Если вы вводили текст и нужно поставить в этой же ячейке курсив на новую строку, тогда нажмите комбинацию клавиш «Ctrl+Enter».

Перенос

Создание ссылки

Здесь мы разберем два варианта: создание ссылки на ячейку, чтобы отправить ее другому пользователю, и как введенный текст сделать ссылкой.

В первом случае выделите ячейки, кликните правой кнопкой по ним и выберите «Получить ссылку на этот диапазон».

Получить ссылку

Откроется окно с созданной ссылкой. Скопируйте ее и можно отправить другому человеку. Когда он по ней перейдет, то откроется таблица в левом верхнем углу которой будет не привычное «1, 2, 3…» и «A, B, C…», а адрес той ячейки, что была крайней левой в выбранном вами диапазоне.

Важно, чтобы тот человек, которому вы отправляете ссылку, имел доступ к Гугл Таблице. Иначе, посмотреть данные у него не получится.

Определенный адрес

Второй вариант – как сделать слово или число в ячейке ссылкой. Снова выделите ее и выберите в контекстном меню «Вставить ссылку».

Вставка ссылки

Появится небольшое окно. В верхнем поле будет указан текст, а ниже должна быть сама ссылка. Поставьте курсив во второе поле и вставьте туда нужную ссылку (ее необходимо скопировать предварительно, например, из адресной строки браузера). Можете выбрать один из предложенных вариантов: сослаться на лист в таблице, определенный диапазон ячеек, или другую книгу.

Дополнительный блок

В примере в поле «Ссылка» я выбрала другой лист данной книги. Для создания нажмите кнопку «Применить».

Теперь «2014» выделится синим цветом и подчеркнется, а после клика по появляющемуся над числом блоку мы перейдем по ссылке – откроется лист с названием «Список».

Переход по ссылке

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...