Функция СУММЕСЛИМН() Сложение с несколькими критериями в EXCEL (Часть 2.Условие И). Примеры и описание

Примеры работы функции СУММЕСЛИМН при выборочном суммировании динамических диапазонов по условию указанному в критериях функции. Как суммировать ячейки по нескольким критериям?

Идея формулы

Прежде, чем погружаться в детали функционирования формулы, полезно понимать, что же она делает по самой своей сути. Смотрим на рисунок.

82806624.png

Мы располагаем таблицей, в которой необходимо просуммировать значения из столбца Количество, но с учётом двух критериев или фильтров, если угодно. Первый критерий – столбец Магазин должен содержать значение Центр, второй критерий – столбец Товар должен содержать значение Компьютер. Оба критерия действуют одновременно или, как говорят, по “И” (а не по “ИЛИ“). То есть нас интересует, сколько компьютеров продал центральный магазин.

Для этого в ячейку G7 мы помещаем формулу СУММЕСЛИМН, в которую передаём 5 параметров:

  • D3:D15 – диапазон, содержащий числа, которые мы собираемся суммировать

  • B3:B15 – диапазон, содержащий значения для сравнения с критерием 1

  • G3 – ячейка, содержащая, собственно, критерий 1 – значение, которое нас интересует – “Центр

  • C3:C15 – диапазон, содержащий значения для сравнения с критерием 2

  • G5 – ячейка, содержащая критерий 2 – “Компьютер

Формула вернёт нам значение 14, так как только 2 строки таблицы удовлетворяют обоим нашим критериям, и обе они содержат число 7. А теперь давайте дадим более формальное описание данной функции.

Примеры использования функции СУММЕСЛИМН в Excel

В отличие от СУММЕСЛИ, в рассматриваемой функции предусмотрена возможность внесения до 127 критериев отбора данных для суммирования. СУММЕСЛИМН удобна для работы с объемными таблицами, содержащими большое число полей данных. Например, если требуется рассчитать общую сумму средств, полученных в результате поставки определенного типа товара указанной компанией в определенную страну, удобно использовать функцию СУММЕСЛИМН.

Динамический диапазон суммирования по условию в Excel

Пример 1. В таблице содержатся данные о успеваемости студентов по некоторому предмету в университете. Определить итоговую оценку для студентов с фамилией, начинающейся на букву «А» при условии, что минимальный балл должен быть не менее 5 (успеваемость студентов оценивается по 10-бальной шкале).

Вид таблицы данных:

Пример 1.

Для расчета суммарного балла согласно установленным критериям используем следующую формулу:

СУММЕСЛИМН.

Описание аргументов:

  • C3:C14 – диапазон ячеек с баллами, из которых будут автоматически выбраны значения для расчета суммы, которые соответствуют установленным критериям;
  • C3:C14 – первый диапазон ячеек, к которому будет применен первый критерий;
  • “>5” – первое условие отбора значений из указанного выше диапазона;
  • B3:B14 – второй диапазон ячеек (с фамилиями студентов), к которому будет применен второй критерий;
  • “А*” – второе условие отбора значений (все фамилии, которые начинаются с буквы «А»).

Результат расчетов:

Динамический диапазон суммирования.

В результате формула автоматически определила динамически изменяемый диапазон в соответствии с условиями отбора значений и просуммировала его.

Как отобразить все скрытые строки или столбцы в Excel?

Василий19:36:00 Add Comment

При работе в Excel вы скрыли много строк и/или столбцов и теперь их надо всех быстро отобразить? Прочитайте эту статью, и вы узнаете, как эт…

Далее…

Примеры

Чтобы использовать эти примеры в Excel, выделите нужные данные в таблице, щелкните их правой кнопкой мыши и выберите команду Копировать. На новом листе щелкните правой кнопкой мыши ячейку A1 и в разделе Параметры вставки выберите команду Использовать форматы конечных ячеек.

Проданное количество

Продукт

Продавец

5

Яблоки

Артем

4

Яблоки

Ольга

15

Артишоки

Артем

3

Артишоки

Ольга

22

Бананы

Артем

12

Бананы

Ольга

10

Морковь

Артем

33

Морковь

Ольга

Формула

Описание

=СУММЕСЛИМН(A2:A9; B2:B9; “=Я*”; C2:C9; “Артем”)

Суммирует количество продуктов, названия которых начинаются с Я и которые были проданы продавцом Артем. Для поиска совпадающих названий продуктов в Criteria_range1 B2:B Criteria_range2 9 в группе Условия1(=A*) используется подп. Затем функция суммирует соответствующие обоим условиям значения в диапазоне ячеек, заданном аргументом Диапазон_суммирования (A2:A9). Результат — 20.

=СУММЕСЛИМН(A2:A9; B2:B9; “<>Бананы”; C2:C9; “Артем”)

Суммирует количество продуктов, которые не являются бананами и которые были проданы продавцом по имени Артем. Он исключает бананы, используя<>в критерии1, “<>Бананы”и ищет имя “Том” в Criteria_range2 C2:C9. Затем функция суммирует соответствующие обоим условиям значения в диапазоне ячеек, заданном аргументом Диапазон_суммирования (A2:A9). Результат — 30.

Задача2 (2 числовых критерия)

Другой задачей может быть нахождение сумм ящиков только тех партий товаров, у которых количество ящиков попадает в определенный интервал, например от 5 до 20 (см. файл примера Лист 2Числа ).

sum-33.png

Формулы строятся аналогично задаче 1: =СУММЕСЛИМН(B2:B13;B2:B13;”>=”&D2;B2:B13;”

Примечание : для удобства, строки, участвующие в суммировании, выделены Условным форматированием с правилом =И($B2>=$D$2;$B2

Распространенные неполадки

Проблема

Описание

Вместо ожидаемого результата отображается 0 (нуль).

Если выполняется поиск текстовых значений, например имени человека, убедитесь в том, что значения аргументов Условие1, 2 заключены в кавычки.

Неверный результат возвращается в том случае, если диапазон ячеек, заданный аргументом Диапазон_суммирования, содержит значение ИСТИНА или ЛОЖЬ.

Значения ИСТИНА и ЛОЖЬ в диапазоне ячеек, заданных аргументом Диапазон_суммирования, оцениваются по-разному, что может приводить к непредвиденным результатам при их суммировании.

Ячейки в аргументе Диапазон_суммирования, которым присвоено значение ИСТИНА, оцениваются как 1. Ячейки, которым присвоено значение ЛОЖЬ, оцениваются как 0 (ноль).

Суммирование с множеством условий.

Имеются данные о заказах и продаже шоколада. Подсчитаем итог совершённых продаж по молочному шоколаду. То есть, у нас два требования: должно совпадать наименование товара и в колонке «Выполнен» должно быть указано «Да».

Первым аргументом мы указываем диапазон суммирования E2:E21, а затем попарно – диапазон условия и само условие для него.

=СУММЕСЛИМН(E2:E21;C2:C21;I2;F2:F21;I3)

В C2:C21 будем искать слово «молочный» с любым его вхождением. То есть, до и после него могут быть еще любые другие символы.

В F2:F21 ищем «Да», то есть отметку о том, что заказ выполнен.

Если ОБА эти требования выполняются, то такой заказ нам подходит, и его стоимость мы учтём.

Как видите, у нас найдено 2 совпадения, в которых был продан молочный шоколад.

Как показать сразу несколько скрытых листов в Excel?

Василий18:50:00 Add Comment

При работе с большими книгами в Excel, часто возникает необходимость скрыть лишние листы, что бы они не мешались в работе. Но что делать, ес…

Далее…

СУММЕСЛИМН для суммирования значений по нескольким условиям в Excel

Пример 3. Используя таблицу из второго примера определить суммарной прибыли от поставок товара №1 в Китай и Грузию на протяжении всего периода (трех месяцев).

Для нахождения искомого значения используем формулу массива (для ввода жмем CTRL+SHIFT+Enter):

Функция СУММЕСЛИМН возвращает массив значений для критериев «Китай» и «Грузия» соответственно, которые суммируются функцией СУММ.

Примечание: если критерии переданы в качестве константы массива для двух и более пар диапазон_условияN; условиеN, результат выполнения формулы будет некорректным.

Полученное значение:

СУММЕСЛИМН для суммирования значений по нескольким условиям.

Рекомендации

Необходимые действия

Описание

Использование подстановочных знаков

Подстановочные знаки, такие как вопросительный знак (?) или звездочка (*), в аргументах Условие1, 2 можно использовать для поиска сходных, но не совпадающих значений.

Вопросительный знак соответствует любому отдельно взятому символу. Звездочка — любой последовательности символов. Если требуется найти именно вопросительный знак или звездочку, следует ввести значок тильды (~) перед вопросительным знаком.

Например, формула =СУММЕСЛИМН(A2:A9; B2:B9; “=Я*”; C2:C9; “Арте?”) будет суммировать все значения с именем, начинающимся на “Арте” и оканчивающимся любой буквой.

Различия между функциями СУММЕСЛИ и СУММЕСЛИМН

Порядок аргументов в функциях СУММЕСЛИ и СУММЕСЛИМН различается. Например, в функции СУММЕСЛИМН аргумент Диапазон_суммирования является первым, а в функции СУММЕСЛИ — третьим. Этот момент часто является источником проблем при использовании данных функций.

При копировании и изменении этих похожих формул нужно следить за правильным порядком аргументов.

Одинаковое количество строк и столбцов для аргументов, задающих диапазоны ячеек

Аргумент Диапазон_условия должен иметь то же количество строк и столбцов, что и аргумент Диапазон_суммирования.

К началу страницы

Особенности использования функции СУММЕСЛИМН в Excel

Функция имеет следующую синтаксическую запись:

=СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)

Описание аргументов:

  • диапазон_суммирования – обязательный аргумент, принимающий ссылку на ячейки с числами, для которых будет вычислено суммарное значение с учетом установленных критериев;
  • диапазон_условия1 – обязательный аргумент, принимающий ссылку на ячейки, в которых содержатся данные для проверки на соответствие заданному критерию;
  • условие1 – обязательный аргумент, принимающий ссылку на ячейку с условием поиска, текстовую запись логического выражения (например, «>=100» или «<>0»), проверяемый текст (например, «Продавец_1», «Товар_1») или числовое значение (Например, 20), определяющие ячейки в диапазоне условия1, для которых будут отобраны и просуммированы данные из диапазона суммирования.

Последующие аргументы являются необязательными для заполнения, а их смысл соответствует аргументам диапазон_условия1; условие1. Всего может быть задано до 127 условий отбора данных для суммирования.

Примечания:

  1. Если в качестве аргумента диапазон_суммирования была передана ссылка на диапазон ячеек, содержащие текстовые строки или пустые значения, функция СУММЕСЛИМН будет их игнорировать.
  2. В качестве условий суммирования данных могут выступать числовые значения, логические выражения, текстовые строки, формулы, ссылки на ячейки, содержащие условия.
  3. Условия проверки в виде текста или выражений с логическими и математическими символами должны быть указаны в кавычках.
  4. Максимальная длина условия, переданного в качестве аргумента условие1 (условие2 и т. д.) не должна превышать 255 символов.
  5. Для создания неточных текстовых критериев поиска требуемых значений можно использовать подстановочные знаки «?» и «*», замещающие один или несколько символов соответственно.
  6. Если в диапазоне ячеек, переданных в качестве аргумента диапазон_суммирования, есть ячейки, содержащие логические ИСТИНА или ЛОЖЬ, они будут автоматически преобразованы к числовым значениям 1 и 0 соответственно и будут учтены в итоговой сумме.
  7. Число ячеек в диапазонах суммирования и условиях должно быть одинаковым, иначе функция СУММЕСЛИМН вернет код ошибки #ЗНАЧ!.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Как СУММЕСЛИМН работает с датами?

Если вы хотите отобрать и сложить какие-то показатели в определенном временном интервале на основе текущей даты, используйте функцию СЕГОДНЯ() в ваших ограничениях, как это показано ниже.

Следующая формула суммирует числа в столбце D, если соответствующая дата в столбце А попадает в последние 7 дней, включая сегодняшний день (предполагается, что сегодня 7 февраля):

=СУММЕСЛИМН(D2:D21;A2:A21;”<=”&СЕГОДНЯ();A2:A21;”>=”&СЕГОДНЯ()-6)

Замечание. Когда вы при составлении ограничения используете другую функцию Excel вместе с логическим оператором, нужно использовать амперсанд (&) для объединения всего выражения в виде текста, например “<=”&СЕГОДНЯ().

Аналогичным образом вы можете использовать функцию Excel СУММЕСЛИ для суммирования каких-то показателей в заданном диапазоне дат. Например, следующая формула также решит нашу задачу:

=СУММЕСЛИ(A2:A21;”>=”&СЕГОДНЯ()-6;D2:D21) – СУММЕСЛИ(A2:A21;”<=”&СЕГОДНЯ();D2:D21)

Однако СУММЕСЛИМН сложение делает гораздо проще и понятнее, не так ли?

См. также

Просмотрите видео об использовании усложненных функций ЕСЛИ, таких как функция СУММЕСЛИМН.

Функция СУММЕСЛИ суммирует только те значения, которые соответствуют одному условию

Функция СУММКВ суммирует несколько значений, предварительно возведя каждое из них в квадрат

Функция СЧЁТЕСЛИ подсчитывает только те значения, которые соответствуют одному условию

Функция СЧЁТЕСЛИМН подсчитывает только те значения, которые соответствуют нескольким условиям

Функция ЕСЛИМН (Microsoft 365, Excel 2016 и более поздних)

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Математические и тригонометрические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Суммирование по пустым и непустым ячейкам.

При анализе отчетов и других данных вам часто может потребоваться суммировать данные, соответствующие пустым или непустым клеткам таблицы.

Критерии Описание Содержание
Пустые ячейки “=” Суммируйте числа, соответствующие пустым, которые не содержат абсолютно ничего – ни формулы, ни строки нулевой длины. =СУММЕСЛИМН(C2:C10;A2:A10;”=”;B2:B10,”=”)
Суммируйте в C2:C10, если соответствующие ячейки в столбцах A и B абсолютно пусты.
«» Суммируйте числа, соответствующие «визуально» пустым, включая те, которые содержат пустые строки, возвращаемые какой-либо другой функцией Excel (например, ячейки с формулой вроде = “”). =СУММЕСЛИМН(C2:C10;A2:A10;””;B2:B10,””)  
Суммируйте в C2:C10 с теми же параметрами, что и в приведенной выше формуле, но с пустыми строками.
Непустые ячейки “<>” Суммируйте числа, соответствующие непустым, включая строки нулевой длины. =СУММЕСЛИМН(C2:C10;A2:A10;”<>”;B2:B10,”<>”) Суммируйте в C2: C10, если соответствующие ячейки в столбцах A и B не пусты, включая ячейки с пустыми строками.
Суммируйте числа, соответствующие непустым, не включая строки нулевой длины. =СУММ(C2:C10) – СУММЕСЛИМН(C2:C10;A2:A10;””;B2:B10,””)
или
{=СУММ((C2:C10)*(ДЛСТР(A2:A10)>0)*(ДЛСТР(B2: B10)>0))}
Если в столбцах A и B содержится текст ненулевой длины, тогда соответствующее число из C складывается. Внимание! Это формула массива! Фигурные скобки вводить не нужно!

А теперь давайте посмотрим, как вы можете использовать формулу СУММЕСЛИМН с «пустыми» и «непустыми» ячейками для реальных данных.

По покупателю «Красный» рассчитаем количество товара в невыполненных заказах. Для этого в столбце B ищем соответствующее название клиента, а в F – пустую ячейку. Если оба требования совпадают, складываем количество товара из столбца D.

=СУММЕСЛИМН(D2:D21;F2:F21;””;B2:B21;”Красный”)

или

=СУММЕСЛИМН(D2:D21;F2:F21;”=”;B2:B21;”Красный”)

Каждое из этих выражений дает верный результат – 144 единицы в заказе от 4 февраля.

Сумма нескольких условий.

А теперь давайте рассчитаем общую стоимость выполненных заказов по двум товарам.

Если мы просто добавим второй критерий в I3, и вместо I2 используем область I2:I3, то расчет будет неверным, поскольку в C2:C21 будем искать товар, в названии которого есть И «черный», И «молочный» одновременно. Ведь таких просто нет.

Поэтому первый вариант расчета таков:

=СУММЕСЛИМН(E2:E21;C2:C21;I2;F2:F21;I4)+СУММЕСЛИМН(E2:E21;C2:C21;I3;F2:F21;I4)

Просто складываем выполненные заказы сначала по первому, а затем по второму наименованию.

Второй вариант: используем элемент массива критериев и функцию СУММ.

=СУММ(СУММЕСЛИМН(E2:E21;C2:C21;{“*молочный*”;”*черный*”};F2:F21;I4))

Как видите, результаты получены одинаковые. Выбирайте способ, который будет для вас проще и понятнее.

Ещё примеры расчета суммы:

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...