Функция COUNTIF (СЧЁТЕСЛИ) в Excel. Как использовать? – ЭКСЕЛЬ ХАК

Использование функции СЧЁТЕФ в Excel для подсчета количества ячеек, которые соответствуют за установленным значениям.

Примеры

Чтобы использовать эти примеры в Excel, скопируйте данные из приведенной ниже таблицы и вставьте их на новый лист в ячейку A1.

Данные

Данные

яблоки

32

апельсины

54

персики

75

яблоки

86

Формула

Описание

=СЧЁТЕСЛИ(A2:A5;”яблоки”)

Количество ячеек, содержащих текст “яблоки” в ячейках А2–А5. Результат — 2.

=СЧЁТЕСЛИ(A2:A5;A4)

Количество ячеек, содержащих текст “персики” (значение ячейки A4) в ячейках А2–А5. Результат — 1.

=СЧЁТЕСЛИ(A2:A5;A2)+СЧЁТЕСЛИ(A2:A5;A3)

Количество ячеек, содержащих текст “яблоки” (значение ячейки A2) и “апельсины” (значение ячейки A3) в ячейках А2–А5. Результат — 3. В этой формуле для указания нескольких критериев, по одному критерию на выражение, функция СЧЁТЕСЛИ используется дважды. Также можно использовать функцию СЧЁТЕСЛИМН.

=СЧЁТЕСЛИ(B2:B5;”>55″)

Количество ячеек со значением больше 55 в ячейках В2–В5. Результат — 2.

=СЧЁТЕСЛИ(B2:B5;”<>”&B4)

Количество ячеек со значением, не равным 75, в ячейках В2–В5. Знак амперсанда (&) объединяет оператор сравнения “<>” (не равно) и значение в ячейке B4, в результате чего получается формула =СЧЁТЕСЛИ(B2:B5;”<>75″). Результат — 3.

=СЧЁТЕСЛИ(B2:B5;”>=32″)-СЧЁТЕСЛИ(B2:B5;”>85″)

Количество ячеек со значением, большим или равным 32 и меньшим или равным 85, в ячейках В2–В5. Результат — 3.

=СЧЁТЕСЛИ(A2:A5;”*”)

Количество ячеек, содержащих любой текст, в ячейках А2–А5. Подстановочный знак “*” обозначает любое количество любых символов. Результат — 4.

=СЧЁТЕСЛИ(A2:A5;”????ки”)

Количество ячеек, строка в которых содержит ровно 7 знаков и заканчивается буквами “ки”, в диапазоне A2–A5. Подставочный знак “?” обозначает отдельный символ. Результат — 2.

Как вызвать функцию СЧЁТЕСЛИ СЧЁТЕСЛИ в MS Excel.

Нажимаем на кнопу Вставить функцию и в открывшемся диалоговом окне Вставка функции, в поле поиск, пишем СЧЁТЕСЛИ. Нажимаем найти. Обращаю внимание, что в поле поиска, писать СЧЁТЕЛСИ, необходимо именно с буквой Ё. По-другому поиск не найдет интересующую нас функцию. По результатам поиска, выбираем нужную нам функцию.

Функция СЧЁТЕСЛИ в MS Excel. Описание и примеры

Описание функции СЧЁТЕСЛИ

СЧЁТЕСЛИ(диапазон; критерий)
Подсчитывает количество непустых ячеек в диапазоне, удовлетворяющих заданному условию.

  • Диапазон — диапазон ячеек по которым необходимо выполнить подсчет;
  • Критерий — условие, определяющее какие ячейки нужно подсчитать. Условие должно быть в виде числа, ссылки на ячейку, выражения и т.д.

Описание

Microsoft Excel функция СЧЁТЕСЛИ в Microsoft Excel подсчитывает количество ячеек в диапазоне, который соответствует заданным критериям.
СЧЁТЕСЛИ – это встроенная в Excel функция, которая относится к категории статистических функций.
Её можно использовать как функцию рабочего листа (WS) в Excel.
Как функцию рабочего листа, функцию СЧЁТЕСЛИ можно ввести как часть формулы в ячейку рабочего листа. Если вы хотите применить несколько критериев, попробуйте использовать функцию СЧЁТЕСЛИМН.

Распространенные неполадки

Проблема

Возможная причина

Для длинных строк возвращается неправильное значение.

Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов.

Для работы с такими строками используйте функцию СЦЕПИТЬ или оператор сцепления &. Пример: =СЧЁТЕСЛИ(A2:A5;”длинная строка”&”еще одна длинная строка”).

Функция должна вернуть значение, но ничего не возвращает.

Аргумент критерий должен быть заключен в кавычки.

Формула СЧЁТЕ ЕСЛИ получает #VALUE! при ссылке на другой таблицу.

Эта ошибка возникает при вычислении ячеек, когда в формуле содержится функция, которая ссылается на ячейки или диапазон в закрытой книге. Для работы этой функции необходимо, чтобы другая книга была открыта.

Аргументы функции

  • range (где нужно искать) – диапазон в рамках которого вы хотите осуществить подсчет ячеек;
  • criteria (что нужно найти) – критерий, по которому все ячейки в указанном вами диапазоне будут проверены на соответствие и только после этого функция подсчитает количество ячеек.

Пример использования функции СЧЁТЕСЛИ

Предположим у нас есть данные по продажам продуктов в магазине:

Таблица с данными по продажам
Подсчитаем количество категорий продуктов, относящихся отдельно к овощам и фруктам (критерий №1 в нашем примере).
В качестве диапазона выбираем ячейки A2:A13 (категория продукта) и задаем критерий подсчета F3 («Овощи»):

Пример №1 использования функции СЧЁТЕСЛИ

Пример №1 использования функции СЧЁТЕСЛИ

Теперь подсчитаем количество проданных продуктов свыше определенного количества килограмм (критерий №2 в нашем примере).
В качестве диапазона выбираем ячейки C2:C13 (объем продаж в кг) и задаем критерий подсчета F7 (“>500”):

Пример №2 использования функции СЧЁТЕСЛИ

Пример №2 использования функции СЧЁТЕСЛИ

Удачи вам и до скорых встреч на страницах блога Tutorexcel.ru!

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Использование СЧЕТЕСЛИ для подсчета дубликатов.

Другое возможное использование функции СЧЕТЕСЛИ в Excel – для поиска дубликатов в одном столбце, между двумя столбцами или в строке.

1. Ищем дубликаты в одном столбце

Эта простое выражение СЧЁТЕСЛИ($A$2:$A$24;A2)>1 найдет все одинаковые записи в A2: A24.

А другая формула СЧЁТЕСЛИ(B2:B24;ИСТИНА) сообщит вам, сколько существует дубликатов:

Для более наглядного представления найденных совпадений я использовал условное форматирование значения ИСТИНА.

2. Сколько совпадений между двумя столбцами?

Сравним список2 со списком1. В столбце Е берем последовательно каждое значение из списка2 и считаем, сколько раз оно встречается в списке1. Если совпадений ноль, значит это уникальное значение. На рисунке такие выделены цветом при помощи условного форматирования.

Выражение  =СЧЁТЕСЛИ($A$2:$A$24;C2) копируем вниз по столбцу Е.

Аналогичный расчет можно сделать и наоборот – брать значения из первого списка и искать дубликаты во втором.

Для того, чтобы просто определить количество дубликатов, можно использовать комбинацию функций СУММПРОИЗВ и СЧЕТЕСЛИ.

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:A24;C2:C24)>0)*(C2:C24<>””))

Подсчитаем количество уникальных значений в списке2:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:A24;C2:C24)=0)*(C2:C24<>””))

Получаем 7 уникальных записей и 16 дубликатов, что и видно на рисунке.

Полезное. Если вы хотите выделить дублирующиеся позиции или целые строки, содержащие повторяющиеся записи, вы можете создать правила условного форматирования на основе формул СЧЕТЕСЛИ, как показано в этом руководстве – правила условного форматирования Excel.

3. Сколько дубликатов и уникальных значений в строке?

Если нужно сосчитать дубликаты или уникальные значения в определенной строке, а не в столбце, используйте одну из следующих формул. Они могут быть полезны, например, для анализа истории розыгрыша лотереи.

Считаем количество дубликатов:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:K2;A2:K2)>1)*(A2:K2<>””))

Видим, что 13 выпадало 2 раза.

Подсчитать уникальные значения:

=СУММПРОИЗВ((СЧЁТЕСЛИ(A2:K2;A2:K2)=1)*(A2:K2<>””))

См. также

Для подсчета непустых ячеек используйте функцию СЧЁТЗ

Для подсчета ячеек на основании нескольких критериев используйте функцию СЧЁТЕСЛИМН

Просмотрите видео об использовании функции СЧЁТЕСЛИМН

Функция СУММЕСЛИ суммирует только те значения, которые соответствуют одному условию

Функция СУММЕСЛИМН суммирует только те значения, которые соответствуют нескольким условиям

Функция ЕСЛИМН (Microsoft 365, Excel 2016 и более поздних)

Для удаления начальных и конечных пробелов в ячейках используйте функцию СЖПРОБЕЛЫ

Для удаления непечатаемых символов в ячейках используйте функцию ПЕЧСИМВ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Статистические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Примеры использования функции СЧЁТЕСЛИ в Excel

Функция СЧЕТЕСЛИ в Excel - Примеры использования

Еще больше полезных приемов в работе со списками данных и функциями в Excel вы узнаете в практическом курсе “От новичка до мастера Excel“. Успей зарегистрироваться по ссылке!

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...