Функции и формулы в Excel с примерами

Разбор функций в Excel, их виды и условия применения. Помощь с Excel в Справочнике Studwork.

Виды основных функций электронной книги

Во время работы с числовыми данными и формулами в Excel часто используют функции, которые существенно облегчают работу с данными. Существует несколько видов таких вспомогательных утилит.

№ 1..jpg

Автосумма

Функция, которая облегчает подсчеты большого количества данных в ячейках. Чтобы ее использовать, необходимо кликнуть на значок. Предположим, у вас есть столбик с числами, которые нужно суммировать. Чтобы не вести подсчеты вручную или при помощи калькулятора, вам необходимо выделить столбик с числами и нажать на кнопку «Автосумма». Сумма появится под столбиком с выбранными числами.

Последние

Эта вкладка предусматривает запуск функций, которые применялись в документе в последнее время. Такая опция позволяет не искать нужный инструмент среди множества вкладок с формулами.

Финансовые функции

Здесь вы можете подсчитывать все, что связанно с финансами. Выбрав эту вкладку, перед вами откроется список с возможными опциями, наиболее часто пользуются «СКИДКОЙ», «ЦЕНОЙ», «ДОХОДОМ».

Полезно знать!

Во время применения математических и инженерных функций необходимо использовать точные значения аргументов. Ошибочные данные недопустимы, так как решение функции будет неправильным.

Логические функции

При помощи логических функций пользователь может проверить существующие значения, а также вернуть результат, когда применена одна из функций «ИСТИНА».

№ 5.jpg

Текстовые функции

Здесь вы сможете преобразовать существующие числовые данные таблицы в текст на разных языках или с использованием определенных символов. В зависимости от того, какой инструмент и аргумент будет установлен.

Дата и время

Эта функция используется в документах для того, чтобы на месте нужного значения (выбранного числа) можно было произвести замену на полную дату или другие указанные аргументы.

Ссылки и массивы

Ссылки и массивы указывают на адрес конкретных ячеек или открывают режим поиска нужного значения. Пользователь только указывает в аргументе требуемое значение.

Математические функции

При помощи них вы сможете решать задачи из алгебры и геометрии, а также пользоваться формулами, которые облегчат решение уравнений, логарифмов, синусов и других значений.

Другие функции

В этом блоке вы найдете «Статистические», «Инженерные», «Аналитические» и другие готовые формулы. Эти буквенные выражения помогут справиться с решением задач в разных областях науки и образования.

№ 10.png

Полезно знать!

Применить функцию можно только к числовым значениям в ячейках документа Excel. Если использовать автоматическую формулу для буквенного выражения системы выдаст ошибку.

Практически в каждой функции Excel предусмотрена установка аргументов. Всего одна формула «ИСТИНА» не имеет возможность указывать аргумент, а автоматически проверяет правильность выражения. Благодаря блоку существующих функций в документе вы с легкостью решите задания разного уровня, а также сможете правильно рассчитать заработную плату сотрудникам или скидку для магазинов.

#1. СУММ

Синтаксис: =СУММ(число1;[число2];…)

число1 — обязательный аргумент.

Функция дает возможность найти сумму отдельных числовых значений, диапазонов, ссылок на ячейки с числовыми значениями или сумму всех этих 3-х видов. Часто используется в подбивании итоговых значений строк или столбцов при формировании отчетов.

Примеры использования

Допустим, у вас есть массив числовых значений и вам нужно посчитать сумму некоторых из них. Используя функцию СУММ, в области аргументов функции мы подставляем нужные ссылки на ячейки и получаем ответ — 312.

В кое-каких случаях в массивах не находятся значения, которые нужно так же просуммировать, и вместо ссылок можем добавить свои числа. Ответ в этом случае — 419.

image14.png

Так как функция работает не только с числовыми значениями, а и с целыми диапазонами, можно найти сумму всего диапазона.

image3.png

Можно не ограничивать себя в количестве значений, которые нужно просуммировать, а посчитать все значения в столбцах или строках. К примеру, просуммируем все значения в первых двух столбцах.

image8.png

Если в одной или нескольких ячейках диапазона окажется не числовое выражение, а текстовое, Excel будет приравнивать эти значения к нулю.

image17.png

работа с эксельФункции Excel относительно отдельных категорий

Категориально разделение формул может быть осуществлено следующим образом:

  • Функции совместимости.
  • Формулы кубов.
  • Функции даты и времени.
  • Финансовые образцы.
  • Текстовые позиции.

функции в эксель примерКаждая основная функция Эксель наделена задачей, которая должна упростить пользователю работу с программой, отобразить нужные данные, сгруппировать их или расформировать. Перед тем, как перейти к категориям, будет рассмотрено несколько часто используемых формул среди юзеров утилиты.

функции эксель и их описание

Строка меню.

Подстрокой заголовка находится строка меню, в которой перечислены группы команд: Главная, Вставка, Разметка страницы, Формулы,Данные, Рецензирование, Вид. Каждая группа объединяет набор команд,имеющих общую функциональную направленность.

1.2.jpg


Рис. 1.2. Вид строки меню

#3. МИН

Синтаксис: =МИН(число1;[число2];…)

число1 — обязательный аргумент.

Функция позволяет найти минимальное числовое значение в указанном списке аргументов. Часто используется при построении финансовой отчетности, когда нужно определить дату начала периода отчета, минимальный чек покупки и другие параметры.

Пример

Допустим, у нас есть диапазон чисел и текстовых выражений, и нужно найти минимальное значение.

image5.png

Например, минимальное значение среди двух выбранных диапазонов A1:D2, A4:D4 и числа 54 будет 21. Пустые поля и текстовые выражения функцией исключаются и в расчетах не используются.

Близкие по назначению функции

=МИНА(значение1;[значение2];…) — находит минимальное значение в списке аргументов, при этом текстовые и ложные логические выражения равняются к нулю, а логическое выражение “ИСТИНА” в ячейке равняется 1.

=МАКС(число1;[число2];…) — находит максимальное значение в списке аргументов, при этом текстовые и пустые выражения игнорируются.

=МАКСА(значение1;[значение2];…) — находит максимальное значение в списке аргументов, при этом текстовые и ложные логические выражения приравниваются к нулю, а логическое выражение “ИСТИНА” в ячейке равняется 1.

Как показать сразу несколько скрытых листов в Excel?

Василий18:50:00 Add Comment

При работе с большими книгами в Excel, часто возникает необходимость скрыть лишние листы, что бы они не мешались в работе. Но что делать, ес…

Далее…

#5. ОКРУГЛ

Синтаксис: =ОКРУГЛ(число; число_разрядов)

число — аргумент.

число_разрядов — до какого разряда округляется число.

Функция ОКРУГЛ применяется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение согласно математическому правилу округления.

К примеру, для округления числа 2,57525 до 2-х символов после запятой можно ввести формулу =ОКРУГЛ(2,57525;2), которая вернет значение 2,58. Эта функция часто используется при построении балансовых и других видов отчетности.

#8. ЕСЛИОШИБКА

Синтаксис: =ЕСЛИОШИБКА(значение;значение_если_ошибка)

значение — аргумент, который проверяется на наличие ошибки

значение_если_ошибка — значение, которое возвращается, если произошла ошибка.

Эта функция проверяет аргумент на равенство значениям ошибок #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0, #ЧИСЛО!, #ИМЯ? или #ПУСТО!. Если выражение в ячейке, которая проверяется, содержит ошибку, функция вернет значение, которое определено в этом случае. Если ошибки нет — результат расчетов или данные ячейки. Часто используется при делении на ноль.

Пример

Возьмем таблицу со значениями выручки и количеством проданных единиц. Нужно найти выручку за одну единицу продукции. Для решения этой задачи выручку делим на количество единиц.

image1.png

Excel ругается, потому что в одном выражении выполняется деление на ноль. Поэтому проверяем на ошибку в соседнем столбце.

image18.png

#9. СЖПРОБЕЛЫ

Синтаксис: =СЖПРОБЕЛЫ(текст)

текст — текстовое значение, из которого необходимо удалить лишние пробелы.

Эту функцию используют для обработки текстов из разных источников. Когда в этих текстах есть лишние пробелы, они удаляются.

Пример

Формула =СЖПРОБЕЛЫ(”      Выручка     с начала                года   “) вернет “Выручка с начала года”, убрав из выражения лишние пробелы.

С помощью функции можно удалить из текста лишние знаки пробела (код символа — 32). В некоторых случаях в тексте может присутствовать знак неразрывного пробела (код — 160). Чтобы удалить эти лишние знаки, нужно использовать следующую формулу: =СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;СИМВОЛ(160);СИМВОЛ(32))). В таком случае функция сначала заменяет все знаки неразрывного пробела на пробел, а после этого удаляет лишние пробелы.

15) СЖПРОБЕЛЫ

Данная функция удаляет все лишние пробелы между словами.

Синтаксис

Формула функции проста: =СЖПРОБЕЛЫ(номер_ячейки)

Пример

Функция позволяет убрать лишние пробелы в тексте

Функция простая и полезная. Единственный минус состоит в том, что она не различает границ слов, и если внутри него стоят пробелы, функция этого не поймет и не удалит их.

Функция не распознает пробелы внутри слов

#10. СЦЕПИТЬ

Синтаксис: =СЦЕПИТЬ(текст1;[текст2];[текст3];…)

текст1 — обязательный аргумент.

Для объединения значений из разных ячеек в одну используется функция СЦЕПИТЬ. Также можно применять аналог — & (амперсанд). Функция часто используется для объединения данных с нескольких столбцов.

Пример

Допустим, у нас есть таблица сотрудников с разделенными ФИО, должностью и возрастом, а в отчете нужно отобразить все эти значения в одной ячейке. Для выполнения этой задачи используем функцию так:

image10.png

Хотите получать дайджест статей?

Одно письмо с лучшими материалами за неделю. Подписывайтесь, чтобы ничего не упустить.

Спасибо за подписку!

Последние материалы

img-mascot-619faf0bec82a355501337.jpg

Как появилась идея говорящих драже M&M’s и в чем успех английского капитана Моргана.

img-liski-619f751aeadcc188867888.jpg

Рассказываем, как диверсифицировать риски в бизнесе.

img-scale-619cf92ed4666983355637.png

Почему вам мало платят и не повышают в должности.

Рейтинг
( 1 оценка, среднее 5 из 5 )
Загрузка ...